On 20/02/17 14:53, David Ahern wrote:
On 2/20/17 3:01 AM, Robert Shearman wrote:
On 18/02/17 01:36, David Ahern wrote:
Add netconf support to MPLS. Allows userpsace to learn and be notified
of changes to 'input' enable setting per interface.
Signed-off-by: David Ahern <d...@cumulusnetworks.com>
---
include/uapi/linux/netconf.h | 1 +
include/uapi/linux/rtnetlink.h | 2 +
net/mpls/af_mpls.c | 212
++++++++++++++++++++++++++++++++++++++++-
net/mpls/internal.h | 2 +-
4 files changed, 214 insertions(+), 3 deletions(-)
diff --git a/include/uapi/linux/netconf.h b/include/uapi/linux/netconf.h
index 45dfad509c4d..159d91c9c2a3 100644
--- a/include/uapi/linux/netconf.h
+++ b/include/uapi/linux/netconf.h
@@ -16,6 +16,7 @@ enum {
NETCONFA_MC_FORWARDING,
NETCONFA_PROXY_NEIGH,
NETCONFA_IGNORE_ROUTES_WITH_LINKDOWN,
+ NETCONFA_MPLS_INPUT_ENABLED,
How about removing "MPLS_" the name? That way it would be usable by
other AFs too, e.g. for the disable_ipv6 sysctl. Perhaps "ENABLED" is
redundant as well.
I could drop the MPLS to NETCONFA_INPUT_ENABLED; just NETCONFA_INPUT is
not very descriptive.
disable_ipv6 has a completely different meaning, so re-use there does
not seem appropriate.
That's a fair point - disable_ipv6 does more than just disabling the
input of IPv6 packets. However, the point still stands in the general
sense - why tie the attribute name to an AF if it's not necessary?
Thanks,
Rob
Thanks for the review.