On 08/23/2016 09:38 AM, Vivien Didelot wrote: > Now that the dsa_switch_driver structure contains only function pointers > as it is supposed to, rename it to the more appropriate dsa_switch_ops, > uniformly to any other operations structure in the kernel. > > No functional changes here, basically just the result of something like: > s/dsa_switch_driver *drv/dsa_switch_ops *ops/g > > However keep the {un,}register_switch_driver functions and their > dsa_switch_drivers list as is, since they represent the -- likely to be > deprecated soon -- legacy DSA registration framework. > > In the meantime, also fix the following checks from checkpatch.pl to > make it happy with this patch: > > CHECK: Comparison to NULL could be written "!ops" > #403: FILE: net/dsa/dsa.c:470: > + if (ops == NULL) { > > CHECK: Comparison to NULL could be written "ds->ops->get_strings" > #773: FILE: net/dsa/slave.c:697: > + if (ds->ops->get_strings != NULL) > > CHECK: Comparison to NULL could be written "ds->ops->get_ethtool_stats" > #824: FILE: net/dsa/slave.c:785: > + if (ds->ops->get_ethtool_stats != NULL) > > CHECK: Comparison to NULL could be written "ds->ops->get_sset_count" > #835: FILE: net/dsa/slave.c:798: > + if (ds->ops->get_sset_count != NULL) > > total: 0 errors, 0 warnings, 4 checks, 784 lines checked > > Signed-off-by: Vivien Didelot <vivien.dide...@savoirfairelinux.com>
Acked-by: Florian Fainelli <f.faine...@gmail.com> Thanks! -- Florian