I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the 
corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng....@intel.com>
Signed-off-by: Baole Ni <baolex...@intel.com>
---
 net/ipv6/af_inet6.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/net/ipv6/af_inet6.c b/net/ipv6/af_inet6.c
index bfa86f0..aca076e 100644
--- a/net/ipv6/af_inet6.c
+++ b/net/ipv6/af_inet6.c
@@ -83,13 +83,13 @@ struct ipv6_params ipv6_defaults = {
 
 static int disable_ipv6_mod;
 
-module_param_named(disable, disable_ipv6_mod, int, 0444);
+module_param_named(disable, disable_ipv6_mod, int, S_IRUSR | S_IRGRP | 
S_IROTH);
 MODULE_PARM_DESC(disable, "Disable IPv6 module such that it is 
non-functional");
 
-module_param_named(disable_ipv6, ipv6_defaults.disable_ipv6, int, 0444);
+module_param_named(disable_ipv6, ipv6_defaults.disable_ipv6, int, S_IRUSR | 
S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(disable_ipv6, "Disable IPv6 on all interfaces");
 
-module_param_named(autoconf, ipv6_defaults.autoconf, int, 0444);
+module_param_named(autoconf, ipv6_defaults.autoconf, int, S_IRUSR | S_IRGRP | 
S_IROTH);
 MODULE_PARM_DESC(autoconf, "Enable IPv6 address autoconfiguration on all 
interfaces");
 
 static __inline__ struct ipv6_pinfo *inet6_sk_generic(struct sock *sk)
-- 
2.9.2

Reply via email to