jingham added a comment.

In D148863#4288186 <https://reviews.llvm.org/D148863#4288186>, @mib wrote:

> It's unfortunate that we're not able to determine easily if the stop is 
> public or not, so I guess this is the best we could do for now.
>
> We could however greatly reduce the amount of changes in the patch by having 
> `select_most_relevant` default to `false` (or the `true` either way). Then, 
> to improve readability, we would only need to add an inline comment before 
> the argument (`GetSelectedFrame(/*select_most_relevant=*/true)`) like Jonas 
> suggested.
>
> Other than that, this looks good to me :)

I thought about that (it would have made my job easier) but I don't want to 
have a default argument.  I want people to have to think about who they are 
returning this too, and if it had a default argument it would be too easy to 
add it somewhere w/o thinking.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D148863/new/

https://reviews.llvm.org/D148863

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to