bulbazord added inline comments.

================
Comment at: 
lldb/source/Plugins/DynamicLoader/Darwin-Kernel/DynamicLoaderDarwinKernel.cpp:816-819
+      ObjectFileMachO *ondisk_objfile_macho =
+          llvm::dyn_cast_or_null<ObjectFileMachO>(
+              m_module_sp ? m_module_sp->GetObjectFile() : nullptr);
+      if (ondisk_objfile_macho) {
----------------
I have a suggestion that may make this easier to read. You already know that 
m_module_sp is valid because you have that as a condition to even enter this 
block. So you can do something like
```
ObjectFileMachO *ondisk_objfile_macho = m_module_sp->GetObjectFile();
```

But right below you only act on this if the object is valid, so you could stick 
it in the if condition itself:
```
if (auto *ondisk_objfile_macho = m_module_sp->GetObjectFile()) {
```


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D145547/new/

https://reviews.llvm.org/D145547

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to