friss added inline comments.

================
Comment at: llvm/include/llvm/DWARFLinker/DWARFLinkerCompileUnit.h:81-82
+
+    /// Is DIE a forward or backward reference?
+    bool Reference : 1;
   };
----------------
When I read the comment, I was confused as I thought the flag was used to 
differentiate between forward and backward references. But in fact it's just 
signaling a reference to a DIE that has not been emitted yet. Maybe tweak the 
comment.


================
Comment at: llvm/lib/DWARFLinker/DWARFLinker.cpp:961
+      uint64_t Attr = 0xBADDEF;
       Unit.noteForwardReference(
           NewRefDie, RefUnit, RefInfo.Ctxt,
----------------
Should we change the name of this function now that it's not only about forward 
references.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D138176/new/

https://reviews.llvm.org/D138176

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to