seehearfeel added inline comments.

================
Comment at: lldb/source/Utility/ArchSpec.cpp:223
 
+    {eByteOrderLittle, 4, 1, 4, llvm::Triple::loongarch32,
+     ArchSpec::eCore_loongarch32, "loongarch32"},
----------------
SixWeining wrote:
> xen0n wrote:
> > `min_opcode_byte_size` should be 4 too, all LoongArch insns are 32 bits 
> > long. Same for `loongarch64`.
> Right. So, the test doesn't cover this change?
OK, thank you.

It is a bit confusing at the first glance.
Maybe "min_opcode_byte_size" should rename to "min_insn_byte_size",
and "max_opcode_byte_size" should rename to "max_insn_byte_size".


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D137057/new/

https://reviews.llvm.org/D137057

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to