mgorny marked 2 inline comments as done. mgorny added inline comments.
================ Comment at: lldb/source/Plugins/Process/gdb-remote/ProcessGDBRemote.cpp:1189-1192 + std::string pid_prefix; + if (GetID() != LLDB_INVALID_PROCESS_ID && + m_gdb_comm.GetMultiprocessSupported()) + pid_prefix = llvm::formatv("p{0:x-}.", GetID()); ---------------- labath wrote: > If we're going to have these in more places, we should add a helper function > to format a pid.tid pair. I'll bear that in mind. ================ Comment at: lldb/source/Plugins/Process/gdb-remote/ProcessGDBRemote.cpp:1190 + std::string pid_prefix; + if (GetID() != LLDB_INVALID_PROCESS_ID && + m_gdb_comm.GetMultiprocessSupported()) ---------------- labath wrote: > Is this really necessary. If I recall correctly, we go through a lot of > trouble to come up with some pid value (resort to hardcoding pid to 1 if > everything fails).. Probably not. I've guessed maybe it could happen somewhat early in the process but I couldn't really reproduce it ever. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D131758/new/ https://reviews.llvm.org/D131758 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits