JDevlieghere added inline comments.

================
Comment at: lldb/source/Interpreter/Options.cpp:457
 
-      if (!options.empty()) {
-        // We have some required options with no arguments
+      if (required_options.size()) {
         strm.PutCString(" -");
----------------
I'm surprised you change this from `!empty()` to `size()`. I personally think 
the former is more readable. Not an issue in practice, but I do believe the STL 
guarantees `::empty` to be `O(1)` while technically `::size` could be `O(n)`, 
though I think in practice they're both `O(1)`. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D123502/new/

https://reviews.llvm.org/D123502

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to