labath added a comment.

Wouldn't want to miss a good bikeshed. Logarithms are cool, but I think 
something like this (untested) snippet would be simpler

  Input.split(Parts, '%');
  Result << Parts[0];
  for (llvm::StringRef Part : drop_begin(Parts)) {
    if (!Part.consumeInteger(10, Idx) && Idx < Replacements.size())
      Result << Replacements[Idx];
    else
      Result << '%';
    Result << Part;
  }


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D120101/new/

https://reviews.llvm.org/D120101

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to