labath accepted this revision. labath added a comment. This revision is now accepted and ready to land.
Yeah, we shouldn't be using these. Personally, I think the names are now unnecessarily long, and I'd go with something shorter. E.g. replacing the double underscore (btw, in python land they abbreviate that to "dunder", so that would be another option) with a single (`g_double_underscore_kCFBooleanFalse` -> `g_kCFBooleanFalse`), but I don't think this is worth bikeshedding over. ================ Comment at: lldb/source/Plugins/Language/CPlusPlus/LibCxxMap.cpp:370 GetValueOffset(iterated_sp); - auto child_sp = iterated_sp->GetChildMemberWithName(g___value_, true); + auto child_sp = iterated_sp->GetChildMemberWithName(g_double_underscore_value_, true); if (child_sp) ---------------- this line is now way above the length limit. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D119915/new/ https://reviews.llvm.org/D119915 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits