kastiglione added inline comments.

================
Comment at: lldb/source/Plugins/Platform/POSIX/PlatformPOSIX.cpp:609
     if (!path_strings) {
-      result_ptr->image_ptr = dlopen(name, 2);
+      result_ptr->image_ptr = dlopen(name, )" DLOPEN_OPTIONS R"();
       if (result_ptr->image_ptr)
----------------
Instead of `DLOPEN_OPTIONS` and string concatenation, what do you think about 
defining `RTLD_LAZY` inside this string of code?

```
static const int RTLD_LAZY = 0x1;

/// code…

result_ptr->image_ptr = dlopen(name, RTLD_LAZY);
```

The main reason I suggest this is putting the name inline like that makes it 
more grep friendly.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98879/new/

https://reviews.llvm.org/D98879

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to