labath accepted this revision. labath added a comment. Looks good.
In D88841#2320410 <https://reviews.llvm.org/D88841#2320410>, @wallace wrote: > - Cannot delete Trace() {}, as there’s a compilation error. Could be because > some constructors have been marked as deleted, so the compiler wants explicit > declarations. Right. I was going to say you can delete those too as they are already deleted on the base class. Except, it turns out, PluginInterface did not have them deleted. Well.. after 0610a25a85 <https://reviews.llvm.org/rG0610a25a85a0a204c994331e1ab275f86010f9ad> it has. :) ================ Comment at: lldb/source/Plugins/Trace/intel-pt/TraceIntelPT.cpp:19 LLDB_PLUGIN_DEFINE_ADV(TraceIntelPT, TraceIntelPT) ---------------- I think `LLDB_PLUGIN_DEFINE` should work fine. The `_ADV` version is for (mostly legacy) cases where the plugin name does not match the class name. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D88841/new/ https://reviews.llvm.org/D88841 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits