kwk marked 2 inline comments as done. kwk added inline comments.
================ Comment at: lldb/source/Breakpoint/BreakpointResolverName.cpp:323 + // passing. + remove_it = false; + } ---------------- jankratochvil wrote: > Now `if (filter_by_function) {}` always overrides any result from `if > (filter_by_cu)`. So it would be faster + more clear to read as: > ``` > if (filter_by_function) { > if (!sc.function || !filter.FunctionPasses(*sc.function)) > remove_it = true; > } else if (filter_by_cu) { > if (!sc.comp_unit || !filter.CompUnitPasses(*sc.comp_unit)) > remove_it = true; > } > ``` > Thanks @jankratochvil ! You were right about the logic. I must have thought to keep as much from the old code and only add to it. But in this case it makes much more sense to structure the logic the way that you've proposed. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D74136/new/ https://reviews.llvm.org/D74136 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits