JDevlieghere added inline comments.
================ Comment at: tools/debugserver/source/CMakeLists.txt:118 + OUTPUT_VARIABLE xcode_dev_dir) + string(STRIP ${xcode_dev_dir} xcode_dev_dir) + ---------------- sgraenitz wrote: > JDevlieghere wrote: > > Why did you make this variable name lowercase? Does that have any semantic > > meaning? > LLVM tends to use lowercase names for local/non-cached variables, e.g. > `update_src_props` in: > https://github.com/llvm-mirror/llvm/blob/master/cmake/modules/AddLLVM.cmake > > I didn't find any guidelines on conventions for CMake, but I thought it's a > good idea. It's a little surprising to mix in such changes to patches that > also have semantic changes. Maybe I should continue to use uppercase names > for now and add a subsequent patch (with a proper title) that does the change > for the whole file. What do you think? Cool, I wasn't aware of the convention. I think either is fine, whatever you prefer. https://reviews.llvm.org/D54476 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits