labath accepted this revision. labath added a comment. This revision is now accepted and ready to land.
Looks fine to me, I'd just ask you to consider shortening the method names a bit. ================ Comment at: include/lldb/Host/FileSystem.h:119-122 + CreateDataBufferFromPath(const llvm::Twine &path, uint64_t size = 0, + uint64_t offset = 0); + std::shared_ptr<DataBufferLLVM> + CreateDataBufferFromPath(const FileSpec &file_spec, uint64_t size = 0, ---------------- Can we streamline these names? I don't think the `FromPath` part brings anything here when the method is on the filesystem class, as it's completely natural and expected for those methods to take paths. Maybe just `CreateDataBuffer` or `ToDataBuffer` Repository: rLLDB LLDB https://reviews.llvm.org/D54272 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits