clayborg added a comment. So the main questions is: do we need a new section enum called eSectionTypeDWARFDebugInfoDWO? If so, then this patch changes. I think I would prefer adding a new enum.
================ Comment at: source/Plugins/SymbolFile/DWARF/SymbolFileDWARFDwo.cpp:68 - if (auto section_sp = - section_list->FindSectionByType(eSectionTypeDWARFDebugInfo, true)) - if (!section_sp->GetName().GetStringRef().endswith("dwo")) ---------------- If dwo has a unique section name, just name a new enum for the .debug_info.dwo. https://reviews.llvm.org/D52403 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits