xiaobai added a comment. In https://reviews.llvm.org/D47801#1123933, @labath wrote:
> In https://reviews.llvm.org/D47801#1123895, @xiaobai wrote: > > > > - rename INCLUDE_IN_FRAMEWORK to something more neutral (USED_BY_LIBLLDB > > > or whatever) > > > - make the liblldb -> tool dependency not conditioned by > > > LLDB_BUILD_FRAMEWORK > > > - remove the lldb->tool dependencies altogether > > > > > > WDYT? > > > > I think that this a good short-term solution. My concern is your suggestion > > doesn't reflect the actual dependencies, but conveniently errs on the side > > of "build it if we think we might need it". I'm not against your > > suggestion, but I'd like to see if we can come up with something better. > > One idea I had was to introduce another target for the framwork itself, > > e.g. lldbFramework, which gets built if LLDB_BUILD_FRAMEWORK is set. It > > would depend on liblldb and all the necessary tools, headers, etc, that the > > framework would need. That way liblldb can depend only on what it needs to > > build instead of treating it as both the library and the entire framework. > > How do you feel about this? > > > The thing I would suggest, if it is not too much trouble, is again to make > the new target framework-agnostic. I.e., in a LLDB_BUILD_FRAMEWORK build, it > would build everything that goes into a framework and package it. Otherwise, > it would just be a convenient way to refer to liblldb and everything that is > needed to make it functional. The reason I'm suggesting that is that then we > could remove the additional dependency management when building lldb driver > by just making the driver depend on this new target. I think I can try to make that happen. https://reviews.llvm.org/D47801 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits