labath added inline comments.
================ Comment at: source/Plugins/Language/CPlusPlus/LibStdcppUniquePointer.cpp:65-76 ValueObjectSP tuple_sp = valobj_sp->GetChildMemberWithName(ConstString("_M_t"), true); + + ValueObjectSP tuple_sp_child = + tuple_sp->GetChildMemberWithName(ConstString("_M_t"), true); + + /* if there is a _M_t child, the pointers are found in the ---------------- This is somewhat nitpicky, but I think we should rename the tuple_sp variable, as in your case, it will not actually hold a tuple (it is some unique_ptr_impl object, IIRC). So, it should have some neutral name, and once you have the actual tuple object, then call it a "tuple". Feel free to move this code into a GetTuple() function or something... Also, we prefer c++-style comments (//). https://reviews.llvm.org/D44015 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits