clayborg added a comment.

Looks nice. Only nit is we probably don't need the m_endian member variable. 
See inlined comment.



================
Comment at: source/Plugins/ABI/SysV-ppc64/ABISysV_ppc64.h:114
+
+  lldb::ByteOrder m_endian;
 };
----------------
Most other code uses "m_byte_order" as the name. That being said, you can 
always just ask the process since it is store in the lldb_private::ABI class so 
you really don't need to store it here if you don't want to, you could add an 
accessor:

```
lldb::ByteOrder GetByteOrder() const { return GetProcessSP()->GetByteOrder(); }
```


https://reviews.llvm.org/D41702



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to