labath added inline comments.
================ Comment at: source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.cpp:534 +Status NativeRegisterContextLinux_ppc64le::ReadVMX() { + void *buf = GetVMXBuffer(); + if (!buf) ---------------- Isn't this somewhat over-engineered? I mean, GetVMXBuffer returns a pointer to a member variable, so it's pretty much impossible for it to be null. And all GetVMXSize does is return the size of that member variable. If we remove all this boilerplate then this becomes something like: ``` int regset = NT_PPC_VMX; return NativeProcessLinux::PtraceWrapper(PTRACE_SETVRREGS, m_thread.GetID(), ®set, &m_vmx_ppc64le, sizeof(m_vmx_ppc64le)); ``` which I think is much easier to follow than jumping through dozens of these tiny functions https://reviews.llvm.org/D39487 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits