jingham added a comment.

Is it horrible of me to ask that we choose a name that is more descriptive than 
DataExtractorEx?  That "Ex" extension to a class name is just such a punt, and 
I'd really rather not encourage it.

The subclass you made adds the ability to:

(a) Dump itself
(b) Extract some Dwarf EH Frame specific bits.

And (b) is only used in DwarfCallFrameInfo.cpp,

So it would be clearer to make a class that just does (a) and call it 
DataExtractorDumpable.

Then you could have a local class override (like DataExtractorEH) to 
DwarfCallFrameInfo that adds the GetGNUEHPointer.  That latter seems awfully 
specific, and probably doesn't need to be sitting out in the general world.  It 
certainly doesn't need to be riding along all the dumpable data extractors.


https://reviews.llvm.org/D30560



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to