We use UINT32_MAX and so forth all over in lldb.  Were you planning to switch 
over all the uses?  That seem like something you should not do unilaterally, 
but we should decide on as a group.

I originally thought maybe this would buy us some type safety, but it looks 
like (and the docs seem to indicate) this is strictly equivalent to UINT32_MAX. 
 So as far as I can tell the change (unlike NULL -> nullptr) has no benefit.

If that's true, then we should only do this if we agree it is a good idea.  

I would prefer not to make this wholesale change.  Substituting a small number 
of very readable characters where all of them are significant for a much larger 
number that bury the interesting bit in the template argument does not to me 
improve readability.

Jim


> On Mar 11, 2016, at 4:31 PM, Eugene Zelenko via lldb-commits 
> <lldb-commits@lists.llvm.org> wrote:
> 
> -        if (no_modules_in_filter || m_module_spec_list.FindFileIndex(0, 
> module_sp->GetFileSpec(), false) != UINT32_MAX)
> +        if (no_modules_in_filter ||
> +            m_module_spec_list.FindFileIndex(0, module_sp->GetFileSpec(), 
> false) != std::numeric_limits<uint32_t>::max())

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to