On Mon Mar 16 11:44:14 2026 +0200, Sakari Ailus wrote:
> Rename "binning" as "bin_hv" in anticipation of having a variable called
> "binning" for another purpose.
> 
> Signed-off-by: Sakari Ailus <[email protected]>
> Reviewed-by: Laurent Pinchart <[email protected]>
> Reviewed-by: Dave Stevenson <[email protected]>

Patch committed.

Thanks,
Sakari Ailus

 drivers/media/i2c/imx219.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

---

diff --git a/drivers/media/i2c/imx219.c b/drivers/media/i2c/imx219.c
index 05717b1e3224..f1e10b13abda 100644
--- a/drivers/media/i2c/imx219.c
+++ b/drivers/media/i2c/imx219.c
@@ -853,7 +853,7 @@ static int imx219_set_pad_format(struct v4l2_subdev *sd,
        const struct imx219_mode *mode;
        struct v4l2_mbus_framefmt *format;
        struct v4l2_rect *crop;
-       u8 bin_h, bin_v, binning;
+       u8 bin_h, bin_v, bin_hv;
        int ret;
 
        format = v4l2_subdev_state_get_format(state, 0);
@@ -886,11 +886,11 @@ static int imx219_set_pad_format(struct v4l2_subdev *sd,
        bin_v = min(IMX219_ACTIVE_AREA_HEIGHT / format->height, 2U);
 
        /* Ensure bin_h and bin_v are same to avoid 1:2 or 2:1 stretching */
-       binning = min(bin_h, bin_v);
+       bin_hv = min(bin_h, bin_v);
 
        crop = v4l2_subdev_state_get_crop(state, 0);
-       crop->width = format->width * binning;
-       crop->height = format->height * binning;
+       crop->width = format->width * bin_hv;
+       crop->height = format->height * bin_hv;
        crop->left = (IMX219_NATIVE_WIDTH - crop->width) / 2;
        crop->top = (IMX219_NATIVE_HEIGHT - crop->height) / 2;
 
_______________________________________________
linuxtv-commits mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to