On Tue Jun 2 14:59:21 2026 +0100, Bryan O'Donoghue wrote:
> commit 66c744e28b69 ("media: venus: assign unique bus_info strings for
> encoder and decoder") introduced the naming convention
> plat:node-addr:video-codec{enc|dec}. Right now Iris does not replicate this
> naming convention.
> 
> When we do v4l2-ctrl --list -devices we see:
> Iris Decoder (platform:aa00000.video-codec):
>         /dev/video0
>         /dev/video1
> 
> Enumerate the bus_info field of the capabilities structure for namespace
> parity and appropriate differentiation:
> Iris Decoder (plat:aa00000.video-codec:dec):
>         /dev/video0
> 
> Iris Encoder (plat:aa00000.video-codec:enc):
>         /dev/video1
> 
> Fixes: 5ad964ad5656 ("media: iris: Initialize and deinitialize encoder 
> instance structure")
> Cc: [email protected]
> Signed-off-by: Bryan O'Donoghue <[email protected]>
> Reviewed-by: Dmitry Baryshkov <[email protected]>
> Signed-off-by: Bryan O'Donoghue <[email protected]>

Patch committed.

Thanks,
Bryan O'Donoghue

 drivers/media/platform/qcom/iris/iris_vidc.c | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

---

diff --git a/drivers/media/platform/qcom/iris/iris_vidc.c 
b/drivers/media/platform/qcom/iris/iris_vidc.c
index 14d63dc76c9b..1c052ca235be 100644
--- a/drivers/media/platform/qcom/iris/iris_vidc.c
+++ b/drivers/media/platform/qcom/iris/iris_vidc.c
@@ -449,14 +449,21 @@ static int iris_enum_frameintervals(struct file *filp, 
void *fh,
 
 static int iris_querycap(struct file *filp, void *fh, struct v4l2_capability 
*cap)
 {
+       struct iris_core *core = video_drvdata(filp);
        struct iris_inst *inst = iris_get_inst(filp);
+       char *info;
 
        strscpy(cap->driver, IRIS_DRV_NAME, sizeof(cap->driver));
 
-       if (inst->domain == DECODER)
+       if (inst->domain == DECODER) {
                strscpy(cap->card, "Iris Decoder", sizeof(cap->card));
-       else
+               info = "dec";
+       } else {
                strscpy(cap->card, "Iris Encoder", sizeof(cap->card));
+               info = "enc";
+       }
+       snprintf(cap->bus_info, sizeof(cap->bus_info),
+                "plat:%s:%s", dev_name(core->dev), info);
 
        return 0;
 }
_______________________________________________
linuxtv-commits mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to