Rename some functions and variables in advance, to make the next patch
looks more clear. The details are as follows:
1. rename dw_apb_ictl_handler() to dw_apb_ictl_handle_irq_cascaded().
2. change (1 << hwirq) to BIT(hwirq).

In function dw_apb_ictl_init():
1. rename local variable irq to parent_irq.
2. add "const struct irq_domain_ops *domain_ops = &irq_generic_chip_ops",
   then replace &irq_generic_chip_ops in other places with domain_ops.

No functional change.

Signed-off-by: Zhen Lei <thunder.leiz...@huawei.com>
Tested-by: Haoyu Lv <lvha...@huawei.com>
---
 drivers/irqchip/irq-dw-apb-ictl.c | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)

diff --git a/drivers/irqchip/irq-dw-apb-ictl.c 
b/drivers/irqchip/irq-dw-apb-ictl.c
index e4550e9c810ba94..5458004242e9d20 100644
--- a/drivers/irqchip/irq-dw-apb-ictl.c
+++ b/drivers/irqchip/irq-dw-apb-ictl.c
@@ -26,7 +26,7 @@
 #define APB_INT_FINALSTATUS_H  0x34
 #define APB_INT_BASE_OFFSET    0x04
 
-static void dw_apb_ictl_handler(struct irq_desc *desc)
+static void dw_apb_ictl_handle_irq_cascaded(struct irq_desc *desc)
 {
        struct irq_domain *d = irq_desc_get_handler_data(desc);
        struct irq_chip *chip = irq_desc_get_chip(desc);
@@ -43,7 +43,7 @@ static void dw_apb_ictl_handler(struct irq_desc *desc)
                        u32 virq = irq_find_mapping(d, gc->irq_base + hwirq);
 
                        generic_handle_irq(virq);
-                       stat &= ~(1 << hwirq);
+                       stat &= ~BIT(hwirq);
                }
        }
 
@@ -73,12 +73,13 @@ static int __init dw_apb_ictl_init(struct device_node *np,
        struct irq_domain *domain;
        struct irq_chip_generic *gc;
        void __iomem *iobase;
-       int ret, nrirqs, irq, i;
+       int ret, nrirqs, parent_irq, i;
        u32 reg;
+       const struct irq_domain_ops *domain_ops = &irq_generic_chip_ops;
 
        /* Map the parent interrupt for the chained handler */
-       irq = irq_of_parse_and_map(np, 0);
-       if (irq <= 0) {
+       parent_irq = irq_of_parse_and_map(np, 0);
+       if (parent_irq <= 0) {
                pr_err("%pOF: unable to parse irq\n", np);
                return -EINVAL;
        }
@@ -120,8 +121,7 @@ static int __init dw_apb_ictl_init(struct device_node *np,
        else
                nrirqs = fls(readl_relaxed(iobase + APB_INT_ENABLE_L));
 
-       domain = irq_domain_add_linear(np, nrirqs,
-                                      &irq_generic_chip_ops, NULL);
+       domain = irq_domain_add_linear(np, nrirqs, domain_ops, NULL);
        if (!domain) {
                pr_err("%pOF: unable to add irq domain\n", np);
                ret = -ENOMEM;
@@ -146,7 +146,8 @@ static int __init dw_apb_ictl_init(struct device_node *np,
                gc->chip_types[0].chip.irq_resume = dw_apb_ictl_resume;
        }
 
-       irq_set_chained_handler_and_data(irq, dw_apb_ictl_handler, domain);
+       irq_set_chained_handler_and_data(parent_irq,
+                               dw_apb_ictl_handle_irq_cascaded, domain);
 
        return 0;
 
-- 
1.8.3



_______________________________________________
linux-snps-arc mailing list
linux-snps-arc@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-snps-arc

Reply via email to