linux-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH 13/21] x86/mm: Introduce helper for checking direct map 1G page support
Yeoreum Yun
[PATCH 01/21] ARM: mm: make nommu pgd_t a scalar
Yeoreum Yun
[PATCH 21/21] Documentation: mm: clarify behaviour of compile-time folded page tables
Yeoreum Yun
Re: [PATCH 21/21] Documentation: mm: clarify behaviour of compile-time folded page tables
Randy Dunlap
Re: [PATCH 21/21] Documentation: mm: clarify behaviour of compile-time folded page tables
Yeoreum Yun
[PATCH 09/21] loongarch: kvm: remove stack copy address of pXd in pXd_offset()
Yeoreum Yun
[PATCH 12/21] mm/pgtable: redefine PGTABLE_LEVEL enum with ascend order from PGD
Yeoreum Yun
[PATCH 19/21] mm/pgtable: disallow calling (pgd|p4d|pud)_page, pgd_page_vaddr() and (p4d|pud)_pgtable with dummy
Yeoreum Yun
[PATCH 16/21] openrisc/pgtable: drop __pmd_offset()
Yeoreum Yun
[PATCH 17/21] mm/pgtable: optimize pmdp_get() and friends for folded pagetable levels
Yeoreum Yun
[PATCH 07/21] mm/pgtable: define (pgd|p4d|pud)_offset_lockless() for folded page tables
Yeoreum Yun
[PATCH 15/21] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Yeoreum Yun
[PATCH 04/21] LoongArch: mm: define pud_leaf() only when PUD exists
Yeoreum Yun
[PATCH 03/21] ARM: mm: remove custom pgdp_get()
Yeoreum Yun
Re: [PATCH 00/21] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
Muhammad Usama Anjum
Re: [PATCH v3 00/13] x86/msr: Drop 32-bit MSR interfaces
Juergen Gross
[Patch V2] dm: use assign_bit() where applicable
Peng Fan (OSS)
Re: [Patch V2] dm: use assign_bit() where applicable
Mikulas Patocka
[PATCH net v2 1/2] mac802154: rx: fix skb leak in beacon and mac_cmd rx paths
Hui Peng
Re: [PATCH] selftests: kvm: Check calloc() return in vcpu_get_reg_list()
Sean Christopherson
Re: [PATCH 11/17] KVM: nVMX: Use pinned pfncache for L1 APIC virtualization pages
David Woodhouse
Re: [PATCH] KVM: selftests: Fix the never-true negative UFFD delay check
Sean Christopherson
[PATCH RFC v3 0/2] virtio-net: add flow filter for receive timestamps
Steffen Trumtrar
[PATCH RFC v3 1/2] virtio-net: support receive timestamp
Steffen Trumtrar
Re: [PATCH RFC v3 1/2] virtio-net: support receive timestamp
Willem de Bruijn
[PATCH RFC v3 2/2] tun: support rx-tstamp
Steffen Trumtrar
Re: [PATCH RFC v3 0/2] virtio-net: add flow filter for receive timestamps
Willem de Bruijn
Re: [PATCH RFC v3 0/2] virtio-net: add flow filter for receive timestamps
Steffen Trumtrar
Re: [PATCH] selftests: kvm: Fix transposed calloc() arguments in the uffd helper
Sean Christopherson
Re: [PATCH v2 0/9] KVM: selftests: Add Zhaoxin CPU support
Sean Christopherson
Re: [PATCH v1 0/2] KVM: x86: cr8 reserved bit check
Sean Christopherson
RE: [PATCH v1 1/4] x86/vmware: Add a bounded panic log sender
Michael Kelley
Re: [PATCH v2 0/2] KVM: selftests: Fix two VMs leaked on early returns
Sean Christopherson
[PATCH net v2 3/3] ieee802154: ca8210: validate data_ind length upfront in ca8210_skb_rx()
Hui Peng
Re: [PATCH net v2 3/3] ieee802154: ca8210: validate data_ind length upfront in ca8210_skb_rx()
netdev-bot+sashiko
Re: [PATCH v2] KVM: selftests: Replace ulong with unsigned long
Sean Christopherson
Re: [PATCH v4 01/14] dma-buf: introduce initial file I/O infrastructure
Pavel Begunkov
[PATCH net-next v4 0/2] selftests: Fix and migrate XDP feature test
Bochao Cao via B4 Relay
[PATCH net-next v4 2/2] selftests/net: Move XDP feature test to driver framework
Bochao Cao via B4 Relay
[PATCH net-next v4 1/2] selftests/bpf: Track test_xdp_features DUT processes
Bochao Cao via B4 Relay
Re: [PATCH 07/17] KVM: pfncache: Add guest-mode pinning (GUEST_USES_PFN successor)
David Woodhouse
Re: [PATCH] KVM: selftests: Fix the bounds of the SEV debug dst buffer check
Sean Christopherson
[PATCH 0/3] KVM: arm64: timers: Program CVAL from the current count when the hardware won't apply the offset
Fuad Tabba
[PATCH 1/3] KVM: arm64: timers: Compute an offset-applied CVAL from the current count
Fuad Tabba
[PATCH 3/3] KVM: arm64: selftests: Test a timer set past the counter's wrap
Fuad Tabba
[PATCH 2/3] KVM: arm64: nv: Read a guest hypervisor's CNTV_CVAL_EL0 from memory on x1e
Fuad Tabba
Re: [Linaro-mm-sig] Re: [PATCH v4 01/14] dma-buf: introduce initial file I/O infrastructure
Pavel Begunkov
[RFC PATCH 0/2] Fix gup_test long-term pin ownership
Richard Cheng
[RFC PATCH 2/2] selftests/mm: Test per-open gup_test pin ownership
Richard Cheng
Re: [RFC PATCH 2/2] selftests/mm: Test per-open gup_test pin ownership
David Hildenbrand (Arm)
[RFC PATCH 1/2] mm/gup_test: Track long-term pins per open file
Richard Cheng
Re: [RFC PATCH 1/2] mm/gup_test: Track long-term pins per open file
David Hildenbrand (Arm)
[PATCH v6 00/13] Add dmabuf read/write via io_uring
Pavel Begunkov
[PATCH v6 07/13] nvme-pci: rename nvme_pci_sgl_set_data to nvme_pci_dma_iter_set_sgl
Pavel Begunkov
[PATCH v6 10/13] io_uring/rsrc: extend buffer update
Pavel Begunkov
[PATCH v6 11/13] io_uring/rsrc: add uncloneable regbuf flag
Pavel Begunkov
[PATCH v6 08/13] nvme-pci: add SGL support for the dmabuf path
Pavel Begunkov
[PATCH v6 13/13] io_uring/rsrc: add dmabuf backed registered buffers
Pavel Begunkov
[PATCH v6 01/13] dma-buf: introduce initial file I/O infrastructure
Pavel Begunkov
[PATCH v6 06/13] nvme-pci: implement dma-buf backed requests
Pavel Begunkov
Re: [PATCH v6 06/13] nvme-pci: implement dma-buf backed requests
Pavel Begunkov
[PATCH v6 03/13] block: always adjust bi_offset on bio_advance_iter
Pavel Begunkov
[PATCH v6 02/13] iov_iter: add iterator type for dmabuf maps
Pavel Begunkov
[PATCH v6 04/13] block: introduce dma map backed bio type
Pavel Begunkov
Re: [PATCH v6 04/13] block: introduce dma map backed bio type
Christoph Hellwig
Re: [PATCH v6 04/13] block: introduce dma map backed bio type
Pavel Begunkov
[PATCH v6 12/13] io_uring/rsrc: add regbuf import flags
Pavel Begunkov
[PATCH v6 05/13] block: add dma-buf support for raw bdev
Pavel Begunkov
[PATCH v6 09/13] io_uring/rsrc: introduce buf registration structure
Pavel Begunkov
[PATCH v7 0/3] kselftest: mm: fix some failure of split_huge_page_test
Yeoreum Yun
[PATCH v7 3/3] kselftest: mm: remove check_huge_shmem()
Yeoreum Yun
Re: [PATCH v7 3/3] kselftest: mm: remove check_huge_shmem()
David Hildenbrand (Arm)
Re: [PATCH v7 3/3] kselftest: mm: remove check_huge_shmem()
Lorenzo Stoakes (ARM)
Re: [PATCH v7 3/3] kselftest: mm: remove check_huge_shmem()
Zi Yan
[PATCH v7 2/3] kselftest: mm: replace usage of /proc/self/smaps for check_huge_xxx() helper
Yeoreum Yun
Re: [PATCH v7 2/3] kselftest: mm: replace usage of /proc/self/smaps for check_huge_xxx() helper
David Hildenbrand (Arm)
Re: [PATCH v7 2/3] kselftest: mm: replace usage of /proc/self/smaps for check_huge_xxx() helper
Yeoreum Yun
Re: [PATCH v7 2/3] kselftest: mm: replace usage of /proc/self/smaps for check_huge_xxx() helper
David Hildenbrand (Arm)
Re: [PATCH v7 2/3] kselftest: mm: replace usage of /proc/self/smaps for check_huge_xxx() helper
Yeoreum Yun
[PATCH v7 1/3] kselftest: mm: prevent random failure of huge page split for khugepaged
Yeoreum Yun
[PATCH 0/2] selftests/cgroup: fix truncated reads of /proc/self/mounts
Shaojie Sun
[PATCH 2/2] selftests/cgroup: don't crash on a truncated mount entry in cg_find_root()
Shaojie Sun
[PATCH 1/2] selftests/cgroup: read the entire file in read_text()
Shaojie Sun
Re: [PATCH 0/2] selftests/cgroup: fix truncated reads of /proc/self/mounts
Tejun Heo
Re: [PATCH 1/4] mm: generalize vmemmap remap architecture support
Oscar Salvador (SUSE)
Re: [PATCH RFC] rpmsg: qcom_smd: reject interrupted channel waits
Konrad Dybcio
[PATCH v4] module: Validate __version_ext_crcs and __version_ext_names section types
Fang Xieyan
[PATCH v10 RESEND 0/9] riscv: add SBI Supervisor Software Events support
Zhanpeng Zhang
[PATCH v10 RESEND 6/9] perf: RISC-V: support callchains with SSE delivery
Zhanpeng Zhang
[PATCH v10 RESEND 2/9] riscv: add support for SBI Supervisor Software Events extension
Zhanpeng Zhang
[PATCH v10 RESEND 5/9] riscv: mm: avoid enabling interrupts for nofault page faults
Zhanpeng Zhang
[PATCH v10 RESEND 7/9] perf: RISC-V: add support for SSE event
Zhanpeng Zhang
[PATCH v10 RESEND 9/9] selftests/riscv: add perf user-stack SSE copy regression test
Zhanpeng Zhang
[PATCH v10 RESEND 8/9] selftests/riscv: add SSE test module
Zhanpeng Zhang
[PATCH v10 RESEND 4/9] drivers: firmware: add riscv SSE support
Zhanpeng Zhang
[PATCH v10 RESEND 1/9] riscv: add SBI SSE extension definitions
Zhanpeng Zhang
[PATCH v10 RESEND 3/9] riscv: sse: mask events during shutdown and kexec
Zhanpeng Zhang
Re: [PATCH 0/3] selftests: Skip SUD tests when unsupported
Christian Loehle
Re: [PATCH] remoteproc: qcom_q6v5_mss: Fix off-by-one error in regulator error cleanup
Sailesh Nandanavanam
Re: [PATCH] remoteproc: qcom_q6v5_mss: Fix off-by-one error in regulator error cleanup
Anup Vishwakarma
Re: [PATCH] dm-verity: add DM_VERITY_VERIFY_ROOTHASH_SIG_FORCE
Mikulas Patocka
Re: [PATCH] dm-verity: add DM_VERITY_VERIFY_ROOTHASH_SIG_FORCE
Ayoub Zaki
Re: [PATCH] dm-verity: add DM_VERITY_VERIFY_ROOTHASH_SIG_FORCE
Mikulas Patocka
[PATCH v2 0/2] kselftest: mm: fix intermittent failure khugepaged test
Yeoreum Yun
[PATCH v2 1/2] kselftest: mm: return fail when child test result is fail in khugepaged
Yeoreum Yun
[PATCH v2 2/2] kselftest: mm: fix intermittent failure khugepaged test
Yeoreum Yun
[PATCH v4 0/4] backlight: qcom-wled: Fix OVP IRQ imbalance and start from the hardware state
David Heidelberg via B4 Relay
[PATCH v4 1/4] backlight: qcom-wled: Fix NULL pointer dereference in wled_remove()
David Heidelberg via B4 Relay
Re: [PATCH v4 1/4] backlight: qcom-wled: Fix NULL pointer dereference in wled_remove()
Konrad Dybcio
[PATCH v4 2/4] backlight: qcom-wled: Fix WLED3 brightness register stride
David Heidelberg via B4 Relay
Re: [PATCH v4 2/4] backlight: qcom-wled: Fix WLED3 brightness register stride
Konrad Dybcio
Re: [PATCH v4 2/4] backlight: qcom-wled: Fix WLED3 brightness register stride
David Heidelberg
[PATCH v4 4/4] backlight: qcom-wled: Read back the programmed brightness at probe
David Heidelberg via B4 Relay
[PATCH v4 3/4] backlight: qcom-wled: Fix unbalanced OVP IRQ enable at probe
David Heidelberg via B4 Relay
[PATCH 0/3] vdso/gettimeofday: Add support for ALARM clocks
Thomas Weißschuh
[PATCH 3/3] vdso/gettimeofday: Add support for CLOCK_REALTIME_ALARM
Thomas Weißschuh
[PATCH 1/3] selftests: vDSO: vdso_test_abi: Also test ALARM clocks
Thomas Weißschuh
[PATCH 2/3] vdso/gettimeofday: Add support for CLOCK_BOOTTIME_ALARM
Thomas Weißschuh
[PATCH v4 0/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
[PATCH v4 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
Re: [PATCH v4 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
David Hildenbrand (Arm)
Re: [PATCH v4 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Lorenzo Stoakes (ARM)
[PATCH v4 1/3] kselftest: mm: rename read_pmd_pagesize() to pmd_psize()
Yeoreum Yun
[PATCH v4 3/3] kselftest: mm: introduce size_to_shift() helper
Yeoreum Yun
Re: [PATCH v4 3/3] kselftest: mm: introduce size_to_shift() helper
David Hildenbrand (Arm)
Re: [PATCH v4 3/3] kselftest: mm: introduce size_to_shift() helper
Zi Yan
[PATCH v2 0/2] KVM: arm64: Fix a vSError staying pending after delivery under pKVM
Fuad Tabba
[PATCH v2 1/2] KVM: arm64: Sync HCR_EL2.VSE back to the host vCPU under pKVM
Fuad Tabba
[PATCH v2 2/2] KVM: arm64: selftests: Check SError is not pending after delivery
Fuad Tabba
[PATCH net v2 2/3] ieee802154: ca8210: prevent stack buffer overflow in hwme_get_request_sync()
Hui Peng
Re: [PATCH net v2 2/3] ieee802154: ca8210: prevent stack buffer overflow in hwme_get_request_sync()
netdev-bot+sashiko
[PATCH net v2 2/2] mac802154: rx: ensure tailroom before appending CRC
Hui Peng
Re: [PATCH net v2 2/2] mac802154: rx: ensure tailroom before appending CRC
netdev-bot+sashiko
[PATCH net v2 2/4] ieee802154: cc2520: flush fifop_irqwork before destroying buffer_mutex in probe
Hui Peng
Re: [PATCH net v2 2/4] ieee802154: cc2520: flush fifop_irqwork before destroying buffer_mutex in probe
netdev-bot+sashiko
[PATCH net v2 3/4] ieee802154: mcr20a: drop corrupted RX frames instead of reading 125 stale bytes
Hui Peng
Re: [PATCH net v2 3/4] ieee802154: mcr20a: drop corrupted RX frames instead of reading 125 stale bytes
netdev-bot+sashiko
[PATCH v4 0/7] net: skb: isolate skb data area allocations into a separate bucket
Kees Cook
[PATCH v4 6/7] mm/slab: Let a bucket set handle __GFP_ACCOUNT
Kees Cook
Re: [PATCH v4 6/7] mm/slab: Let a bucket set handle __GFP_ACCOUNT
Harry Yoo
Re: [PATCH v4 6/7] mm/slab: Let a bucket set handle __GFP_ACCOUNT
Kees Cook
Re: [PATCH v4 6/7] mm/slab: Let a bucket set handle __GFP_ACCOUNT
Pedro Falcato
[PATCH v4 2/7] mm/slab: Give bucket caches the alignment of the caches they mirror
Kees Cook
Re: [PATCH v4 2/7] mm/slab: Give bucket caches the alignment of the caches they mirror
Harry Yoo
Re: [PATCH v4 2/7] mm/slab: Give bucket caches the alignment of the caches they mirror
Kees Cook
[PATCH v4 5/7] mm/slab: Provide kmalloc type fallback for bucket allocations
Kees Cook
Re: [PATCH v4 5/7] mm/slab: Provide kmalloc type fallback for bucket allocations
Pedro Falcato
[PATCH v4 7/7] net: skb: isolate skb data area allocations into a separate bucket
Kees Cook
[PATCH v4 1/7] mm/slab: Mark the kmem_buckets_create() context as a Context: section
Kees Cook
Re: [PATCH v4 1/7] mm/slab: Mark the kmem_buckets_create() context as a Context: section
Harry Yoo
Re: [PATCH v4 1/7] mm/slab: Mark the kmem_buckets_create() context as a Context: section
Pedro Falcato
[PATCH v4 3/7] mm/slab: Add kmem_buckets_destroy()
Kees Cook
[PATCH v4 4/7] mm/slab: Add tests for the existing kmem_buckets behaviour
Kees Cook
[PATCH net v2 1/3] ieee802154: ca8210: prevent stack buffer overflow in ca8210_rx_done()
Hui Peng
Re: [PATCH net v2 1/3] ieee802154: ca8210: prevent stack buffer overflow in ca8210_rx_done()
David Laight
Re: [PATCH net v2 1/3] ieee802154: ca8210: prevent stack buffer overflow in ca8210_rx_done()
netdev-bot+sashiko
[PATCH net v2 4/4] ieee802154: mcr20a: fix 1-byte out-of-bounds read in mcr20a_handle_tx()
Hui Peng
Re: [PATCH net v2 4/4] ieee802154: mcr20a: fix 1-byte out-of-bounds read in mcr20a_handle_tx()
netdev-bot+sashiko
[PATCH net v2 1/4] ieee802154: cc2520: ensure tailroom before skb_put() in promiscuous TX
Hui Peng
Re: [PATCH 2/4] nvdimm/pmem: avoid HWPoison flag updates for clean pages
Gupta, Pankaj
Re: [PATCH 2/4] nvdimm/pmem: avoid HWPoison flag updates for clean pages
Oscar Salvador (SUSE)
Re: [PATCH 2/4] nvdimm/pmem: avoid HWPoison flag updates for clean pages
Muchun Song
Re: [PATCH] KVM: selftests: Fix arm64 sysreg header dependencies
Fuad Tabba
Re: [PATCH] KVM: selftests: Fix arm64 sysreg header dependencies
Oliver Upton
Re: [PATCH] KVM: selftests: Fix arm64 sysreg header dependencies
Fuad Tabba
[PATCH v2] README: rename to README.rst and make the doc references links
Osman Ahmadzai
Re: [PATCH v2] README: rename to README.rst and make the doc references links
Randy Dunlap
Re: [PATCH v2] README: rename to README.rst and make the doc references links
Matthew Wilcox
Re: [PATCH v2] README: rename to README.rst and make the doc references links
Randy Dunlap
Re: [PATCH 3/4] mm: add shared read-only vmemmap support for FS-DAX
Gupta, Pankaj
Re: [PATCH 3/4] mm: add shared read-only vmemmap support for FS-DAX
Muchun Song
Re: [PATCH 3/4] mm: add shared read-only vmemmap support for FS-DAX
Gupta, Pankaj
Re: [PATCH 3/4] mm: add shared read-only vmemmap support for FS-DAX
Oscar Salvador (SUSE)
Re: [PATCH 3/4] mm: add shared read-only vmemmap support for FS-DAX
Muchun Song
[RFC] Referencing local variables with SmPL?
Markus Elfring
Re: [PATCH 0/2] iio: flow: slf3s: fix and test the vdd supply balance
Jonathan Cameron
Re: [PATCH v4 00/11] Dynamic Housekeeping Management (DHM) via CPUSets
Jing Wu
[PATCH v13] mm/bpf: Add bpf_proactive_reclaim kfunc
Hui Zhu
Re: [PATCH v13] mm/bpf: Add bpf_proactive_reclaim kfunc
Kumar Kartikeya Dwivedi
Re: [PATCH v13] mm/bpf: Add bpf_proactive_reclaim kfunc
patchwork-bot+netdevbpf
Re: [PATCH v10 00/17] AD9910 Direct Digital Synthesizer
Jonathan Cameron
[PATCH v5 04/17] fscrypt: stop setting PG_private on bounce page
Zi Yan
Re: [PATCH v5 04/17] fscrypt: stop setting PG_private on bounce page
Lance Yang
[PATCH] Documentation: kunit: Fix KUNIT_DEFINE_ACTION_WRAPPER() argument order
Kees Cook
[PATCH 00/17] KVM: Use atomic SRCU for gfn-to-pfn cache, reinstate guest mode for x86 nesting
David Woodhouse
[PATCH 04/17] KVM: x86/xen: Don't dirty track "vCPU info" page
David Woodhouse
[PATCH 16/17] KVM: nSVM: Cache L1's IO permissions map pages
David Woodhouse
[PATCH 17/17] KVM: selftests: Add nested transition benchmark
David Woodhouse
[PATCH 12/17] KVM: selftests: Add nested VMX APIC cache invalidation test
David Woodhouse
[PATCH 11/17] KVM: nVMX: Use pinned pfncache for L1 APIC virtualization pages
David Woodhouse
[PATCH 03/17] KVM: x86/xen: Explicitly tag "shared info" page as never being dirty tracked
David Woodhouse
[PATCH 01/17] KVM: pfncache: Use atomic SRCU for readers instead of a rwlock
David Woodhouse
Re: [PATCH 01/17] KVM: pfncache: Use atomic SRCU for readers instead of a rwlock
Hillf Danton
Re: [PATCH 01/17] KVM: pfncache: Use atomic SRCU for readers instead of a rwlock
David Woodhouse
Re: [PATCH 01/17] KVM: pfncache: Use atomic SRCU for readers instead of a rwlock
Hillf Danton
Re: [PATCH 01/17] KVM: pfncache: Use atomic SRCU for readers instead of a rwlock
Paolo Bonzini
[PATCH 15/17] KVM: nSVM: Cache L1's MSR permissions map pages
David Woodhouse
[PATCH 13/17] KVM: x86: Move nested GPC lock helpers to x86.h as kvm_gpc_lock_page()
David Woodhouse
[PATCH 14/17] KVM: nSVM: Use a gfn_to_pfn_cache for the vmcb12 page
David Woodhouse
[PATCH 10/17] KVM: nVMX: Implement cache for L1 MSR bitmap
David Woodhouse
Earlier messages
Later messages