This small series redesigns the memory deposit logic when Linux runs on Hyper-V hypervisor as a privileged VM, the second patch explains why. The series is split in three patches, the first patch renames the functions to _old and that makes the 2 main patch much easier and nicer to review. Last patch just removes the *_old functions from first patch.
Thanks, -Mukesh V2: o Enhance comments o In case of contiguous and failure, don't goto err_free_dep_pages but just return also. It should not happen, but if it does, hypevisor will throw error. V1: o Remove hv_alloc_contig_pages() and make contiguous allocation part of hv_alloc_dep_pages(), thus getting rid of the kmalloc. o Instead of stubbing out functions, rename them to *_old. Mukesh R (3): mshv: Rename memory deposit memory functions to _old mshv: Redesign hypervisor memory deposit logic mshv: Remove unused *_old memory deposit functions drivers/hv/hv_proc.c | 246 +++++++++++++++++++-------------- drivers/hv/mshv_root_hv_call.c | 10 +- include/asm-generic/mshyperv.h | 5 - 3 files changed, 141 insertions(+), 120 deletions(-) -- 2.51.2.vfs.0.1

