On Wed, 15 Jul 2026 16:02:10 +0800, Haofeng Li wrote:
> Commit 57fbad15c2ee ("stackleak: Rename STACKLEAK to KSTACK_ERASE")
> renamed the LKDTM crash type and selftest configuration but missed the
> entry in tests.txt.
> 
> As a result, the selftest generates STACKLEAK_ERASING.sh, which run.sh
> skips because the LKDTM DIRECT trigger only exposes KSTACK_ERASE. Rename
> the test entry so the generated runner uses the registered crash type.
> 
> [...]

Applied to for-linus/hardening, thanks!

[1/1] selftests/lkdtm: rename STACKLEAK_ERASING to KSTACK_ERASE
      https://git.kernel.org/kees/c/b3a7aa9c0020

Take care,

-- 
Kees Cook


Reply via email to