linux-doc
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Tzung-Bi Shih
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Bartosz Golaszewski
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Greg Kroah-Hartman
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Bartosz Golaszewski
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Tzung-Bi Shih
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Jason Gunthorpe
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Bartosz Golaszewski
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Tzung-Bi Shih
Re: [PATCH 01/23] gpiolib: Correct wrong kfree() usage for `kobj->name`
Bartosz Golaszewski
[PATCH 10/23] gpiolib: cdev: Don't check struct gpio_chip in gpio_chrdev_open()
Tzung-Bi Shih
[PATCH 14/23] gpiolib: cdev: Leverage revocable for linehandle_fileops
Tzung-Bi Shih
[PATCH 13/23] gpiolib: cdev: Leverage revocable for gpio_fileops
Tzung-Bi Shih
[PATCH 05/23] gpiolib: cdev: Correct return code on memory allocation failure
Tzung-Bi Shih
[PATCH 16/23] gpiolib: cdev: Leverage revocable for lineevent_fileops
Tzung-Bi Shih
[PATCH 06/23] gpiolib: Access `gpio_bus_type` in gpiochip_setup_dev()
Tzung-Bi Shih
[PATCH 18/23] gpiolib: Leverage revocable for gpiolib_sops
Tzung-Bi Shih
[PATCH 07/23] gpiolib: Remove redundant check for struct gpio_chip
Tzung-Bi Shih
[PATCH 08/23] gpiolib: sysfs: Remove redundant check for struct gpio_chip
Tzung-Bi Shih
[PATCH 20/23] revocable: Add Kunit test case for DEFINE_REVOCABLE()
Tzung-Bi Shih
[PATCH 15/23] gpiolib: cdev: Leverage revocable for line_fileops
Tzung-Bi Shih
[PATCH 21/23] selftests: revocable: Add test case for DEFINE_REVOCABLE()
Tzung-Bi Shih
[PATCH 09/23] gpiolib: Ensure struct gpio_chip for gpiochip_setup_dev()
Tzung-Bi Shih
[PATCH 11/23] selftests: gpio: Add gpio-cdev-uaf tests
Tzung-Bi Shih
[PATCH 17/23] gpiolib: cdev: Leverage revocable for lineinfo_changed_notify
Tzung-Bi Shih
[PATCH 12/23] gpiolib: Add revocable provider handle for struct gpio_chip
Tzung-Bi Shih
[PATCH 19/23] revocable: Support to define revocable consumer handle on stack
Tzung-Bi Shih
[PATCH 23/23] gpiolib: Remove unused `chip` and `srcu` in struct gpio_device
Tzung-Bi Shih
[PATCH 22/23] gpiolib: Leverage revocable for other independent lifecycle instances
Tzung-Bi Shih
Re: [PATCH 22/23] gpiolib: Leverage revocable for other independent lifecycle instances
Johan Hovold
Re: [PATCH 22/23] gpiolib: Leverage revocable for other independent lifecycle instances
Johan Hovold
Re: [PATCH 22/23] gpiolib: Leverage revocable for other independent lifecycle instances
Tzung-Bi Shih
Re: [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Bartosz Golaszewski
Re: [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Laurent Pinchart
Re: [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Tzung-Bi Shih
Re: [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Bartosz Golaszewski
Re: [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Tzung-Bi Shih
Re: [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Bartosz Golaszewski
Re: (subset) [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Bartosz Golaszewski
Re: (subset) [PATCH 00/23] gpiolib: Adopt revocable mechanism for UAF prevention
Tzung-Bi Shih
[PATCH v7 0/3] drivers/base: Introduce revocable
Tzung-Bi Shih
[PATCH v7 1/3] revocable: Revocable resource management
Tzung-Bi Shih
Re: [PATCH v7 1/3] revocable: Revocable resource management
Danilo Krummrich
Re: [PATCH v7 1/3] revocable: Revocable resource management
Bartosz Golaszewski
Re: [PATCH v7 1/3] revocable: Revocable resource management
Danilo Krummrich
Re: [PATCH v7 1/3] revocable: Revocable resource management
Laurent Pinchart
Re: [PATCH v7 1/3] revocable: Revocable resource management
Danilo Krummrich
Re: [PATCH v7 1/3] revocable: Revocable resource management
Bartosz Golaszewski
Re: [PATCH v7 1/3] revocable: Revocable resource management
Jason Gunthorpe
Re: [PATCH v7 1/3] revocable: Revocable resource management
Bartosz Golaszewski
Re: [PATCH v7 1/3] revocable: Revocable resource management
Bartosz Golaszewski
[PATCH v7 2/3] revocable: Add Kunit test cases
Tzung-Bi Shih
[PATCH v7 3/3] selftests: revocable: Add kselftest cases
Tzung-Bi Shih
Re: [PATCH v7 0/3] drivers/base: Introduce revocable
Greg Kroah-Hartman
Re: [PATCH v7 0/3] drivers/base: Introduce revocable
Laurent Pinchart
Re: [PATCH v7 0/3] drivers/base: Introduce revocable
Danilo Krummrich
Re: [PATCH v7 0/3] drivers/base: Introduce revocable
Jason Gunthorpe
Re: [PATCH v7 0/3] drivers/base: Introduce revocable
Danilo Krummrich
[PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Bobby Eshleman
[PATCH net-next v10 1/5] net: devmem: rename tx_vec to vec in dmabuf binding
Bobby Eshleman
[PATCH net-next v10 5/5] selftests: drv-net: devmem: add autorelease tests
Bobby Eshleman
[PATCH net-next v10 2/5] net: devmem: refactor sock_devmem_dontneed for autorelease split
Bobby Eshleman
[PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Bobby Eshleman
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Jakub Kicinski
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Bobby Eshleman
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Jakub Kicinski
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Bobby Eshleman
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Jakub Kicinski
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Bobby Eshleman
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Jakub Kicinski
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Stanislav Fomichev
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Jakub Kicinski
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Bobby Eshleman
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Jakub Kicinski
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Bobby Eshleman
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Jakub Kicinski
Re: [PATCH net-next v10 4/5] net: devmem: document NETDEV_A_DMABUF_AUTORELEASE netlink attribute
Bobby Eshleman
[PATCH net-next v10 3/5] net: devmem: implement autorelease token management
Bobby Eshleman
Re: [PATCH net-next v10 3/5] net: devmem: implement autorelease token management
Jakub Kicinski
Re: [PATCH net-next v10 3/5] net: devmem: implement autorelease token management
Bobby Eshleman
Re: [PATCH net-next v10 3/5] net: devmem: implement autorelease token management
Mina Almasry
Re: [PATCH net-next v10 3/5] net: devmem: implement autorelease token management
Bobby Eshleman
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Jakub Kicinski
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Bobby Eshleman
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Jakub Kicinski
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Mina Almasry
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Bobby Eshleman
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Jakub Kicinski
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Stanislav Fomichev
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Bobby Eshleman
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Pavel Begunkov
Re: [PATCH net-next v10 0/5] net: devmem: improve cpu cost of RX token management
Jens Axboe
[PATCH] doc: kgdb: Add description about rodata=off kernel parameter
junan
Re: [PATCH] doc: kgdb: Add description about rodata=off kernel parameter
Daniel Thompson
Re: [PATCH] doc: kgdb: Add description about rodata=off kernel parameter
Jonathan Corbet
Re: [PATCH] doc: kgdb: Add description about rodata=off kernel parameter
Jonathan Corbet
[PATCH net-next v9 0/9] Add support for providers with large rx buffer
Pavel Begunkov
[PATCH net-next v9 2/9] net: reduce indent of struct netdev_queue_mgmt_ops members
Pavel Begunkov
[PATCH net-next v9 3/9] net: add bare bone queue configs
Pavel Begunkov
[PATCH net-next v9 4/9] net: pass queue rx page size from memory provider
Pavel Begunkov
[PATCH net-next v9 7/9] eth: bnxt: support qcfg provided rx page size
Pavel Begunkov
[PATCH net-next v9 8/9] selftests: iou-zcrx: test large chunk sizes
Pavel Begunkov
[PATCH net-next v9 1/9] net: memzero mp params when closing a queue
Pavel Begunkov
Re: [PATCH net-next v9 1/9] net: memzero mp params when closing a queue
patchwork-bot+netdevbpf
[PATCH net-next v9 9/9] io_uring/zcrx: document area chunking parameter
Pavel Begunkov
[PATCH net-next v9 6/9] eth: bnxt: adjust the fill level of agg queues with larger buffers
Pavel Begunkov
[PATCH net-next v9 5/9] eth: bnxt: store rx buffer size per queue
Pavel Begunkov
Re: [PATCH net-next v9 0/9] Add support for providers with large rx buffer
Pavel Begunkov
Re: [PATCH net-next v9 0/9] Add support for providers with large rx buffer
Jakub Kicinski
[PATCH RESEND] docs: kselftest: remove link to obsolete wiki
Brett A C Sheffield
Re: [PATCH RESEND] docs: kselftest: remove link to obsolete wiki
Bagas Sanjaya
Re: [PATCH RESEND] docs: kselftest: remove link to obsolete wiki
SeongJae Park
[PATCH] kunit: add bash completion
Ryota Sakamoto
Re: [PATCH] kunit: add bash completion
David Gow
Re: [PATCH] kunit: add bash completion
Ryota Sakamoto
Re: [PATCH] kunit: add bash completion
Jani Nikula
Re: [PATCH] kunit: add bash completion
Ryota Sakamoto
[PATCH v2] docs: netdev: refine 15-patch limit
Simon Horman
Re: [PATCH v2] docs: netdev: refine 15-patch limit
patchwork-bot+netdevbpf
[PATCH v8 net-next 00/14] AccECN protocol case handling series
chia-yu . chang
[PATCH v8 net-next 04/14] tcp: ECT_1_NEGOTIATION and NEEDS_ACCECN identifiers
chia-yu . chang
[PATCH v8 net-next 07/14] tcp: accecn: retransmit downgraded SYN in AccECN negotiation
chia-yu . chang
[PATCH v8 net-next 05/14] tcp: disable RFC3168 fallback identifier for CC modules
chia-yu . chang
[PATCH v8 net-next 10/14] tcp: accecn: unset ECT if receive or send ACE=0 in AccECN negotiaion
chia-yu . chang
[PATCH v8 net-next 09/14] tcp: accecn: retransmit SYN/ACK without AccECN option or non-AccECN SYN/ACK
chia-yu . chang
[PATCH v8 net-next 01/14] tcp: try to avoid safer when ACKs are thinned
chia-yu . chang
[PATCH v8 net-next 02/14] gro: flushing when CWR is set negatively affects AccECN
chia-yu . chang
[PATCH v8 net-next 03/14] selftests/net: gro: add self-test for TCP CWR flag
chia-yu . chang
Re: [PATCH v8 net-next 03/14] selftests/net: gro: add self-test for TCP CWR flag
Jakub Kicinski
[PATCH v8 net-next 06/14] tcp: accecn: handle unexpected AccECN negotiation feedback
chia-yu . chang
[PATCH v8 net-next 11/14] tcp: accecn: fallback outgoing half link to non-AccECN
chia-yu . chang
[PATCH v8 net-next 13/14] tcp: accecn: enable AccECN
chia-yu . chang
[PATCH v8 net-next 08/14] tcp: add TCP_SYNACK_RETRANS synack_type
chia-yu . chang
[PATCH v8 net-next 12/14] tcp: accecn: detect loss ACK w/ AccECN option and add TCP_ACCECN_OPTION_PERSIST
chia-yu . chang
[PATCH v8 net-next 14/14] selftests/net: packetdrill: add TCP Accurate ECN cases
chia-yu . chang
[PATCH v2 00/23] mm: balloon infrastructure cleanups
David Hildenbrand (Red Hat)
[PATCH v2 07/23] mm/balloon_compaction: use a device-independent balloon (list) lock
David Hildenbrand (Red Hat)
[PATCH v2 15/23] mm/balloon_compaction: assert that the balloon_pages_lock is held
David Hildenbrand (Red Hat)
Re: [PATCH v2 15/23] mm/balloon_compaction: assert that the balloon_pages_lock is held
Lorenzo Stoakes
[PATCH v2 18/23] mm/vmscan: drop inclusion of balloon_compaction.h
David Hildenbrand (Red Hat)
Re: [PATCH v2 18/23] mm/vmscan: drop inclusion of balloon_compaction.h
Lorenzo Stoakes
[PATCH v2 03/23] powerpc/pseries/cmm: remove cmm_balloon_compaction_init()
David Hildenbrand (Red Hat)
Re: [PATCH v2 03/23] powerpc/pseries/cmm: remove cmm_balloon_compaction_init()
Lorenzo Stoakes
Re: [PATCH v2 03/23] powerpc/pseries/cmm: remove cmm_balloon_compaction_init()
David Hildenbrand (Red Hat)
[PATCH v2 01/23] vmw_balloon: adjust BALLOON_DEFLATE when deflating while migrating
David Hildenbrand (Red Hat)
Re: [PATCH v2 01/23] vmw_balloon: adjust BALLOON_DEFLATE when deflating while migrating
Lorenzo Stoakes
[PATCH v2 05/23] mm/balloon_compaction: centralize adjust_managed_page_count() handling
David Hildenbrand (Red Hat)
Re: [PATCH v2 05/23] mm/balloon_compaction: centralize adjust_managed_page_count() handling
Liam R. Howlett
[PATCH v2 10/23] mm/balloon_compaction: drop fs.h include from balloon_compaction.h
David Hildenbrand (Red Hat)
Re: [PATCH v2 10/23] mm/balloon_compaction: drop fs.h include from balloon_compaction.h
Lorenzo Stoakes
[PATCH v2 14/23] mm/balloon_compaction: move internal helpers to balloon_compaction.c
David Hildenbrand (Red Hat)
Re: [PATCH v2 14/23] mm/balloon_compaction: move internal helpers to balloon_compaction.c
Lorenzo Stoakes
[PATCH v2 11/23] drivers/virtio/virtio_balloon: stop using balloon_page_push/pop()
David Hildenbrand (Red Hat)
Re: [PATCH v2 11/23] drivers/virtio/virtio_balloon: stop using balloon_page_push/pop()
Lorenzo Stoakes
[PATCH v2 13/23] mm/balloon_compaction: fold balloon_mapping_gfp_mask() into balloon_page_alloc()
David Hildenbrand (Red Hat)
Re: [PATCH v2 13/23] mm/balloon_compaction: fold balloon_mapping_gfp_mask() into balloon_page_alloc()
Lorenzo Stoakes
[PATCH v2 12/23] mm/balloon_compaction: remove balloon_page_push/pop()
David Hildenbrand (Red Hat)
Re: [PATCH v2 12/23] mm/balloon_compaction: remove balloon_page_push/pop()
Lorenzo Stoakes
[PATCH v2 08/23] mm/balloon_compaction: remove dependency on page lock
David Hildenbrand (Red Hat)
[PATCH v2 16/23] mm/balloon_compaction: mark remaining functions for having proper kerneldoc
David Hildenbrand (Red Hat)
Re: [PATCH v2 16/23] mm/balloon_compaction: mark remaining functions for having proper kerneldoc
Lorenzo Stoakes
[PATCH v2 09/23] mm/balloon_compaction: make balloon_mops static
David Hildenbrand (Red Hat)
Re: [PATCH v2 09/23] mm/balloon_compaction: make balloon_mops static
Lorenzo Stoakes
[PATCH v2 22/23] mm: rename CONFIG_MEMORY_BALLOON -> CONFIG_BALLOON
David Hildenbrand (Red Hat)
Re: [PATCH v2 22/23] mm: rename CONFIG_MEMORY_BALLOON -> CONFIG_BALLOON
Lorenzo Stoakes
Re: [PATCH v2 22/23] mm: rename CONFIG_MEMORY_BALLOON -> CONFIG_BALLOON
David Hildenbrand (Red Hat)
Re: [PATCH v2 22/23] mm: rename CONFIG_MEMORY_BALLOON -> CONFIG_BALLOON
Michael S. Tsirkin
Re: [PATCH v2 22/23] mm: rename CONFIG_MEMORY_BALLOON -> CONFIG_BALLOON
Michael S. Tsirkin
Re: [PATCH v2 22/23] mm: rename CONFIG_MEMORY_BALLOON -> CONFIG_BALLOON
David Hildenbrand (Red Hat)
Re: [PATCH v2 22/23] mm: rename CONFIG_MEMORY_BALLOON -> CONFIG_BALLOON
Lorenzo Stoakes
[PATCH v2 19/23] mm: rename balloon_compaction.(c|h) to balloon.(c|h)
David Hildenbrand (Red Hat)
Re: [PATCH v2 19/23] mm: rename balloon_compaction.(c|h) to balloon.(c|h)
Lorenzo Stoakes
[PATCH v2 21/23] mm: rename CONFIG_BALLOON_COMPACTION to CONFIG_BALLOON_MIGRATION
David Hildenbrand (Red Hat)
Re: [PATCH v2 21/23] mm: rename CONFIG_BALLOON_COMPACTION to CONFIG_BALLOON_MIGRATION
Lorenzo Stoakes
[PATCH v2 20/23] mm/kconfig: make BALLOON_COMPACTION depend on MIGRATION
David Hildenbrand (Red Hat)
Re: [PATCH v2 20/23] mm/kconfig: make BALLOON_COMPACTION depend on MIGRATION
Lorenzo Stoakes
[PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
David Hildenbrand (Red Hat)
Re: [PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
Lorenzo Stoakes
Re: [PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
David Hildenbrand (Red Hat)
Re: [PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
Vlastimil Babka
Re: [PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
Lance Yang
Re: [PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
David Hildenbrand (Red Hat)
Re: [PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
Michael S. Tsirkin
Re: [PATCH v2 23/23] MAINTAINERS: move memory balloon infrastructure to "MEMORY MANAGEMENT - BALLOON"
David Hildenbrand (Red Hat)
Re: [PATCH v2 00/23] mm: balloon infrastructure cleanups
Michael S. Tsirkin
Re: [PATCH v2 00/23] mm: balloon infrastructure cleanups
David Hildenbrand (Red Hat)
[PATCH v2 17/23] mm/balloon_compaction: remove "extern" from functions
David Hildenbrand (Red Hat)
Re: [PATCH v2 17/23] mm/balloon_compaction: remove "extern" from functions
Lorenzo Stoakes
[PATCH v2 06/23] vmw_balloon: stop using the balloon_dev_info lock
David Hildenbrand (Red Hat)
Re: [PATCH v2 06/23] vmw_balloon: stop using the balloon_dev_info lock
Lorenzo Stoakes
Re: [PATCH v2 06/23] vmw_balloon: stop using the balloon_dev_info lock
David Hildenbrand (Red Hat)
[PATCH v2 04/23] mm/balloon_compaction: centralize basic page migration handling
David Hildenbrand (Red Hat)
Re: [PATCH v2 04/23] mm/balloon_compaction: centralize basic page migration handling
Lorenzo Stoakes
Re: [PATCH v2 04/23] mm/balloon_compaction: centralize basic page migration handling
David Hildenbrand (Red Hat)
Re: [PATCH v2 04/23] mm/balloon_compaction: centralize basic page migration handling
David Hildenbrand (Red Hat)
Re: [PATCH v2 04/23] mm/balloon_compaction: centralize basic page migration handling
David Hildenbrand (Red Hat)
[PATCH v2 02/23] vmw_balloon: remove vmballoon_compaction_init()
David Hildenbrand (Red Hat)
Re: [PATCH v2 02/23] vmw_balloon: remove vmballoon_compaction_init()
Lorenzo Stoakes
Re: [PATCH v2 00/23] mm: balloon infrastructure cleanups
Andrew Morton
Re: [PATCH v2 00/23] mm: balloon infrastructure cleanups
David Hildenbrand (Red Hat)
Re: [PATCH v9 02/26] dt-bindings: riscv: zicfilp and zicfiss in dt-bindings (extensions.yaml)
Paul Walmsley
Earlier messages
Later messages