On 2025/4/21 15:10, Christophe JAILLET wrote:
Le 21/04/2025 à 07:51, Su Hui a écrit :
It's safer to use size_add() to replace open-coded aithmetic in
allocator
arguments, because size_add() can prevent possible overflow problem.
Signed-off-by: Su Hui <su...@nfschina.com>
---
include/crypto/aead.h | 3 ++-
include/crypto/akcipher.h | 4 +++-
include/crypto/kpp.h | 3 ++-
3 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/include/crypto/aead.h b/include/crypto/aead.h
index 0e8a41638678..cf212d28fe18 100644
--- a/include/crypto/aead.h
+++ b/include/crypto/aead.h
@@ -10,6 +10,7 @@
#include <linux/atomic.h>
#include <linux/container_of.h>
+#include <linux/overflow.h>
You could move this 1 line below, to keep alphabetical order.
And why do you say that it is redundant in your follow-up mail?
Thanks for your suggestion, I didn't notice this alphabetical order at
first :( .
Because I found that <linux/crypto.h> includes <linux/slab.h>, and
<linux/slab.h> includes <linux/overflow.h>, so this overflow.h is
redundant.
#include <linux/crypto.h>
#include <linux/slab.h>
And I also found these <linux/{atomic,container_of,slab,types,list}.h>
is included by
<linux/crypto.h>, I am trying to remove these redundant headers in v2 patch.
It's sad that remving these duplicate header files didn't save any
compilation time,
only save some code space.
#include <linux/types.h>
@@ -433,7 +434,7 @@ static inline struct aead_request
*aead_request_alloc(struct crypto_aead *tfm,
--- a/include/crypto/kpp.h
+++ b/include/crypto/kpp.h
@@ -11,6 +11,7 @@
#include <linux/atomic.h>
#include <linux/container_of.h>
+#include <linux/overflow.h>
You could move this 1 line below, to keep alphabetical order.
This overflow.h is redundant too.
#include <linux/crypto.h>