On Thu, Oct 01, 2015 at 10:10:43PM -0700, Tadeusz Struk wrote:
>
>  /**
> + * crypto_akcipher_get_len() -- Get minimum len for output buffer
> + *
> + * Function returns minimum dest buffer size for a given key
> + *
> + * @tfm:     AKCIPHER tfm handle allocated with crypto_alloc_akcipher()
> + *
> + * Return: minimum len for output buffer or error code in key hasn't been set
> + */
> +static inline int crypto_akcipher_get_len(struct crypto_akcipher *tfm)

Please rename this to something like

        crypto_akcipher_maxsize

I presume it's actually the maximum size that would be required
of the destination buffer rather than the minimum.  The latter
would seem to be quite useless.

Cheers,
-- 
Email: Herbert Xu <herb...@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt
--
To unsubscribe from this list: send the line "unsubscribe linux-crypto" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to