2013/6/18 Tejun Heo <t...@kernel.org>:
> On Tue, Jun 18, 2013 at 10:31:32PM +0900, Akinobu Mita wrote:
>>  /**
>> + * sg_miter_seek - reposition mapping iterator
>> + * @miter: sg mapping iter to be seeked
>> + * @offset: number of bytes to plus the current location
>> + *
>> + * Description:
>> + *   Sets the offset of @miter to its current location plus @offset bytes.
>> + *
>> + * Notes:
>> + *   This function must be called just after sg_miter_start() or 
>> sg_miter_stop()
>
> It's not gonna be hard to make this function to handle any state,
> right?  Wouldn't it be better to do that?  It's a pretty generic
> feature after all.  Also, maybe a better name is sg_miter_skip()?

Yes.  This limitation can be removed by calling sg_miter_stop() at
the front of sg_miter_seek().  Also, renaming it to sg_miter_skip()
sounds good.
--
To unsubscribe from this list: send the line "unsubscribe linux-crypto" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to