-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128695/
-----------------------------------------------------------

(Updated Aug. 22, 2016, 7:16 a.m.)


Status
------

This change has been marked as submitted.


Review request for KMymoney.


Changes
-------

Submitted with commit d52980d06dbf44badc32a9d5f49f14ed6d658b7e by ?ukasz 
Wojni?owicz to branch master.


Repository: kmymoney


Description
-------

1) processInvestLine should identify fields by integers and not strings
(better performance),
2) processing of type, symbol, name fields contains unnecessary code
and m_brokerage isn't doing anything usefull,
3) type field needs amount, price, quanity so process them first
4) QIF creation is not essential to processing (less memory),
5) QList statements is not needed and consumed memory exponentially,
6) investCsvImport doesn't do anything usefull besides copying data from
processInvestLine so merge both,
7) transaction types should be identified by enum from
MyMoneyStatement::Transaction,
8) redefinedlg.cpp contains duplicate code,
9) validation of selected column contains duplicate code,
10) new QMaps: m_colTypeNum, m_colNumType, m_colTypeName for handling
columns information,
11) validateMemoComboBox for validating copied memo field,
12) csvSplit not needed.


Diffs
-----

  kmymoney/plugins/csvimport/csvwizard.cpp 435006b 
  kmymoney/plugins/csvimport/investprocessing.h 27cea07 
  kmymoney/plugins/csvimport/investprocessing.cpp e20c1de 
  kmymoney/plugins/csvimport/redefinedlg.h e242d62 
  kmymoney/plugins/csvimport/redefinedlg.cpp 8afa4ad 

Diff: https://git.reviewboard.kde.org/r/128695/diff/


Testing
-------


Thanks,

Łukasz Wojniłowicz

Reply via email to