This is not verifiable in the main kernel since it affected stub code which is not in use with that config. The only kernel running into it was linux-kvm. This builds now and double checked that this was done by the change:
@@ -483,11 +483,6 @@ static inline int devm_pwmchip_add(struct device *dev, struct pwm_chip *chip) return -EINVAL; } -static inline int devm_pwmchip_add(struct device *dev, struct pwm_chip *chip) -{ - return -EINVAL; -} Note that the function name deleted is the same as the name of the function directly before (as the @@ hint shows). ** Changed in: linux (Ubuntu Lunar) Importance: Undecided => Medium ** Tags removed: verification-needed-lunar-linux ** Tags added: verification-done-lunar-linux -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-kvm in Ubuntu. https://bugs.launchpad.net/bugs/2039542 Title: Remove duplication of devm_pwmchip_add function definition Status in linux package in Ubuntu: Invalid Status in linux-kvm package in Ubuntu: New Status in linux source package in Lunar: Fix Committed Status in linux-kvm source package in Lunar: Fix Released Bug description: SRU Justification: [Impact] * Upstream commit 88da4e8113110d5f4ebdd2f8cd0899e300cd1954 "pwm: Add a stub for devm_pwmchip_add()", was applied the second time during the latest upstream patchset (#LP: 2037005) for cycle 2023.10.02. * `git am` did not detect that the changes were applied, leading to the same function definition being duplicated. * This was not caught when the main kernel was built because this code is under CONFIG_PWM=n. The main kernel and pretty much every kernel apart from linux-kvm, has CONFIG_PWM=y. * The problem was caught when lunar:linux-kvm was cranked and build failed with the following error: ``` In file included from /build/lunar/drivers/acpi/acpi_lpss.c:23: /build/lunar/include/linux/pwm.h:486:19: error: redefinition of 'devm_pwmchip_add' 486 | static inline int devm_pwmchip_add(struct device *dev, struct pwm_chip *chip) | ^~~~~~~~~~~~~~~~ /build/lunar/include/linux/pwm.h:481:19: note: previous definition of 'devm_pwmchip_add' with type 'int(struct device *, struct pwm_chip *)' 481 | static inline int devm_pwmchip_add(struct device *dev, struct pwm_chip *chip) | ^~~~~~~~~~~~~~~~ ``` [Fix] * Revert the commit. * Because this affects only linux:kvm, it is necessary to apply this fix for lunar:linux-kvm for cycle 2023.10.02, but the main kernel can wait for the next cycle. [Test plan] * Since linux-kvm was the only kernel that had this issue, I applied the patch to kvm after I rebased the latest changes from the parent and did a build test. * I also did a build test for linux:main just to make sure [Where problems could occur] * This change is pretty non-invasive, so nowhere To manage notifications about this bug go to: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/2039542/+subscriptions -- Mailing list: https://launchpad.net/~kernel-packages Post to : kernel-packages@lists.launchpad.net Unsubscribe : https://launchpad.net/~kernel-packages More help : https://help.launchpad.net/ListHelp