https://bugs.kde.org/show_bug.cgi?id=502679

--- Comment #6 from Mark Wielaard <m...@klomp.org> ---
diff --git a/auxprogs/ltp-tester.sh b/auxprogs/ltp-tester.sh
new file mode 100755
index 000000000..8ee1a8778
--- /dev/null
+++ b/auxprogs/ltp-tester.sh
@@ -0,0 +1,72 @@
+#!/bin/bash

OK, /bin/bash instead of /bin/sh because of bash mapfiles usage below.

+set -e
+
+SELF_DIR=$(dirname $(readlink -f $0))
+LTP_DIR=${1:-$SELF_DIR/auxchecks/ltp-full-20250130}

Can we derive this for the setting of AUX_CHECK_DIR and LTP_VERSION (currently
LTP_DIR_NAME) in the Makefile (export those variable or pass then as arguments
to the script/

+ORIG_PATH=${PATH}
+OUTPUT_LOG="${OUTPUT_LOG:-$LTP_DIR/valgrind-ltp.log}"

OK, so it can be set or derived from LTP_DIR.
Pondering whether it should be set relative to SELF_DIR to make sure bunsen
picks it up.
For the builders we would set the AUX_CHECK_DIR to somewhere outside the
builddir, so we keep a cache of the download tar.gz and builddir.

+DIFFCMD="${DIFFCMD:-diff -u}"

Isn't this a little overkil? What would the alternative to diff -u be?
Asking because I think this makes the script less readable than it could be
(IMHO).

+VALGRIND="${VALGRIND:-$SELF_DIR/../vg-in-place}"

I do like this.

+>$OUTPUT_LOG

So this means all stdout output goes to OUTPUT_LOG from this point on?
but then ...

+myLog ()
+{
+    msg="$1"
+    echo "$msg"
+    echo -e "FAIL: $msg" >> $OUTPUT_LOG
+}

Isn't this doing the output twice?

+cd $LTP_DIR

Ack.

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to