lukeyan2023 commented on issue #3013:
URL: 
https://github.com/apache/incubator-streampark/issues/3013#issuecomment-1703722779

   > Thank you for the detailed feedback. We will work quickly to identify and 
fix this bug. 💪🔧
   
   
![image](https://github.com/apache/incubator-streampark/assets/108530647/958c4d02-1d30-4465-988f-3c6f7f06d960)
   
   
   
![image](https://github.com/apache/incubator-streampark/assets/108530647/717d62e3-8bdf-48f5-b44d-50db83ac2e49)
   
   The above two screenshots are from the Flink 1.17.1 official document
   
   In actual testing, the SP address in Figure 2 should use the format 2 in 
Figure 1 to function properly, but using the format 1 in Figure 1 will fail, 
which is also the reason for the current error.
   
   By reviewing the source code, I understand that the process should be as 
follows: 
     
     First, trigger the generation of sp, then streampark will obtain the 
generated sp from Flink and write it to the database. 
     Second, when restoring from sp, it will obtain the sp parameters from the 
database.
   
    So if we fix this issue, should we obtain the format 2  in Figure 1 when 
obtaining sp from Flink, so that the code in other places doesn't need to be 
changed?
   


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to