[ https://jira.codehaus.org/browse/SUREFIRE-1055?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=341345#comment-341345 ]
Kristian Rosenvold commented on SUREFIRE-1055: ---------------------------------------------- The plot thickens; everything is reported correctly to org.apache.maven.surefire.junitcore.ConcurrentRunListener#testStarting > Parallel JUnit does not run all test methods with parallel=classesAndMethods > perCoreThreadCount=false useUnlimitedThreads=true and threadCountMethods > specified > --------------------------------------------------------------------------------------------------------------------------------------------------------------- > > Key: SUREFIRE-1055 > URL: https://jira.codehaus.org/browse/SUREFIRE-1055 > Project: Maven Surefire > Issue Type: Bug > Components: Junit 4.7+ (parallel) support, Maven Failsafe Plugin, > Maven Surefire Plugin > Affects Versions: 2.16 > Reporter: Chris Hansen > Attachments: surefire-output.txt > > > Some test methods are skipped at random with the below configuration. When > test methods are skipped in this way, only one method in the class runs. > Running tests repeatedly with no code change often yields a different number > of tests with each run (e.g. see the attached surefire-output.txt). Tests > that take longer to run are less likely to be affected. This affects version > 2.16 of Surefire and Failsafe equally. > Here is a simple test project which reproduces the issue: > https://github.com/hansenc/SUREFIRE-1055 > It has a few simple test classes with a naming convention for how many test > methods are in each class (e.g. Methods4Test has 4 test methods). > {code:xml} > <plugin> > <groupId>org.apache.maven.plugins</groupId> > <artifactId>maven-surefire-plugin</artifactId> > <version>2.16</version> > <configuration> > <parallel>classesAndMethods</parallel> > <perCoreThreadCount>false</perCoreThreadCount> > <useUnlimitedThreads>true</useUnlimitedThreads> > <threadCountMethods>3</threadCountMethods> > </configuration> > </plugin> > {code} -- This message was sent by Atlassian JIRA (v6.1.6#6162)