[
https://jira.codehaus.org/browse/MWAR-256?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Robert Scholte closed MWAR-256.
-------------------------------
Resolution: Won't Fix
Assignee: Robert Scholte
As said by Stéphane and Dennis: if you want to reuse the classes, it should be
a separate project. If classes and webapp are very close related, make a small
multimodule of it:
{noformat}
acme-project
+ acme-classes
+ acme-webapp
{noformat}
Even though both artifacts have their own extension, they share the same
{{pom.xml}}, which says that the packaging-type is {{war}}. Maven and
maven-plugins _can_ depend on the packaging-type specified in the pom, so you'd
better keep those artifacts apart if you don't accept a classifier.
> it's not possible to create classes attachment without classifier
> -----------------------------------------------------------------
>
> Key: MWAR-256
> URL: https://jira.codehaus.org/browse/MWAR-256
> Project: Maven 2.x WAR Plugin
> Issue Type: Bug
> Affects Versions: 2.1.1
> Reporter: Rafal Krzewski
> Assignee: Robert Scholte
>
> I would like to package classes in my war-packaged project into a jar, but I
> don't want to use default 'classes' classifier assigned by the plugin. The
> generated artifacts have distinct packaging types, so there is no conflict
> and the classifier provides no useful additional information. Using the
> following configuration:
> {quote}
> {{<configuration>}}
> {{<classesClassifier/>}}
> {{</configuration>}}
> {quote}
> Results in "classes" classifier being used anyway. If I understand the
> behavior correctly Plexus assigns the variable it's default value, when
> presented an empty input. I don't think this can be fixed in way that is both
> clean and backward compatible. Either the default value will change, which
> would break existing builds that don't specify plugin version explicitly, or
> some clunky additional parameter like
> {{<useClassesClassifier>false</useClassesClassifier>}}, or magic value like
> {{<classesClassifier>NONE</classesClassifier>}} need to be introduced.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira