[ https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Stephen Connolly reopened MNG-6081: ----------------------------------- Maven 3.4.0 has been dropped. See [this thread|https://mail-archives.apache.org/mod_mbox/maven-dev/201701.mbox/%3CCA%2BnPnMx-e7kGYy3Hp87v8hLGdhp1q%3DtKLx_6QuZ4kGUqHEBGcw%40mail.gmail.com%3E] for more details. This issue will need to be re-scheduled for a Maven release in the (hopefully near) future. > Log refactoring - Method Invocation Replaced By Variable > -------------------------------------------------------- > > Key: MNG-6081 > URL: https://issues.apache.org/jira/browse/MNG-6081 > Project: Maven > Issue Type: Improvement > Components: core > Affects Versions: 3.3.9 > Reporter: Nemo Chen > Assignee: Michael Osipov > Priority: Minor > Fix For: 3.4.0 > > Attachments: MNG-6081.patch > > > *Method Invocation Replaced By Variable* > In file: > apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java > from line 70: > {code} > String keptVersion = kept.getVersion(); > if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : > keptVersion != null ) > { > logger.debug( indent + omitted + " (removed - nearer found: " + > kept.getVersion() + ")" ); > } > {code} > the "kept.getVersion()" can be replaced with "keptVersion" for the sake of > simplicity and readability. -- This message was sent by Atlassian JIRA (v6.3.4#6332)