[ 
https://issues.apache.org/jira/browse/MNG-6119?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15667673#comment-15667673
 ] 
Guillaume Boué commented on MNG-6119:
-------------------------------------

This is not a bug in Maven, but in the {{checksum-maven-plugin}} that is used. 
It is attaching the computed MD5 with a type of {{.md5}} instead of {{md5}} [in 
this part of the 
code|https://github.com/nicoulaj/checksum-maven-plugin/blob/1.3/src/main/java/net/nicoulaj/maven/plugins/checksum/artifacts/ArtifactAttacher.java#L19],
 and the extension comes from 
[here|https://github.com/nicoulaj/checksum-maven-plugin/blob/1.3/src/main/java/net/nicoulaj/maven/plugins/checksum/execution/target/OneHashPerFileTarget.java#L108-L114].
 This should be reported as an issue on its GitHub.

But why are you using this plugin to begin with? You can also create the MD5 
(and SHA-1) digest of the artifacts with the 
[{{createChecksum}}|http://maven.apache.org/plugins/maven-install-plugin/install-mojo.html#createChecksum]
 parameter of the Install Plugin. Just configure it with:

{code:xml}
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-install-plugin</artifactId>
  <version>2.5.2</version>
  <configuration>
    <createChecksum>true</createChecksum>
  </configuration>
</plugin>
{code}



> Artifact has bad name
> ---------------------
>
>                 Key: MNG-6119
>                 URL: https://issues.apache.org/jira/browse/MNG-6119
>             Project: Maven
>          Issue Type: Bug
>          Components: Plugins and Lifecycle
>            Reporter: James youngman
>         Attachments: commons-jelly-2.0-src.zip, commons-jelly-2.0-src.zip.txt
>
>
> When I try to save an md5 checksum in my local repo the name is incorrect.
> [INFO] --- maven-install-plugin:2.5.2:install (default-install) @ 
> ant-commons-jelly ---
> [INFO] Installing target\ant-commons-jelly.jar.md5 to 
> C:\Users\jyoungma\.m2\repository\commons-jelly\ant-commons-jelly\2.0\ant-commons-jelly-2.0..md5



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to