[ https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Michael Osipov closed MNG-6081. ------------------------------- Resolution: Fixed Fixed with [e07978bdca0fe80ba059c686ac92229065b0fd44|https://git-wip-us.apache.org/repos/asf?p=maven.git;a=commit;h=e07978bdca0fe80ba059c686ac92229065b0fd44]. > Log refactoring - Method Invocation Replaced By Variable > -------------------------------------------------------- > > Key: MNG-6081 > URL: https://issues.apache.org/jira/browse/MNG-6081 > Project: Maven > Issue Type: Improvement > Components: core > Affects Versions: 3.3.9 > Reporter: Nemo Chen > Assignee: Michael Osipov > Priority: Minor > Fix For: 3.4.0 > > Attachments: MNG-6081.patch > > > *Method Invocation Replaced By Variable* > In file: > apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java > from line 70: > {code} > String keptVersion = kept.getVersion(); > if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : > keptVersion != null ) > { > logger.debug( indent + omitted + " (removed - nearer found: " + > kept.getVersion() + ")" ); > } > {code} > the "kept.getVersion()" can be replaced with "keptVersion" for the sake of > simplicity and readability. -- This message was sent by Atlassian JIRA (v6.3.4#6332)