[ https://issues.apache.org/jira/browse/MNG-2478?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15281255#comment-15281255 ]
Anders Hammar commented on MNG-2478: ------------------------------------ I'd vote for changing the name to "resources-filtered". The reason being that it will then be listed next to the resources folder in alpabetical order (which is IMHO most often used). If we go with "filtered-resources" it will be IMHO not so obvious for the user when listing the folders. Compare (war project): * java * resources * resources-filtered * webapp with * filtered-resources * java * resources * webapp > add filtered resource directories to super POM > ---------------------------------------------- > > Key: MNG-2478 > URL: https://issues.apache.org/jira/browse/MNG-2478 > Project: Maven > Issue Type: New Feature > Components: FDPFC, POM > Affects Versions: 2.0.4 > Environment: any > Reporter: Jörg Hohwiller > Assignee: Christian Schulte > Fix For: 3.4.0 > > > The super POM contains default folders for resources that are NOT filtered > (src/main/resources and src/test/resources). If one (additionally) needs a > filtered resources folder, it needs to override the default and therefore has > to add all default folders if he does NOT want to "loose" the defaults. > To make this easier my suggestion is to add filtered resource folders to the > super POM. This should also fit to the philosophy of maven that aims to have > defaults and only declare as little custom configuration as needed. > My personal favorite for the foldernames would be "templates" but to make > things more obvious to the user maybe "filtered-resources" would be better. > Actually I do not care to much about the name... > So the resources in the super POM should look like this: > <resources> > <resource> > <directory>src/main/resources</directory> > </resource> > <!-- BEGIN: addition --> > <resource> > <directory>src/main/filtered-resources</directory> > <filtering>true</filtering> > </resource> > <!-- END: addition --> > </resources> > <testResources> > <testResource> > <directory>src/test/resources</directory> > </testResource> > <!-- BEGIN: addition --> > <testResource> > <directory>src/test/filtered-resources</directory> > <filtering>true</filtering> > </testResource> > <!-- END: addition --> > </testResources> -- This message was sent by Atlassian JIRA (v6.3.4#6332)