liurenjie1024 commented on issue #1118:
URL: https://github.com/apache/iceberg-rust/issues/1118#issuecomment-2766198351

   > > I think if a client calls `remove_all(table.location)`, this should work 
and be safe. So I would argue we should treat the input always as a directory / 
append a path.
   > 
   > I have a suggestion that rename this API to `remove_dir_all` which 
indicate that it only removes a dir recursively. And in this API, we make sure 
that both `abc` and `abc/` works correctly. What do you think?
   > 
   > This also aligns with std's 
[`remove_dir_all`](https://doc.rust-lang.org/stable/std/fs/fn.remove_dir_all.html).
   > 
   > Or are you expecting us to first check if `abc/` exists and then decide 
whether to remove a prefix or a directory?
   > 
   > I'm fine with both approaches at the iceberg FileIO side.
   
   +1 for following std's naming convention to have different methods for 
`remove_dir_all` and `remove_dir`(for empty dir)


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: issues-unsubscr...@iceberg.apache.org

For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@iceberg.apache.org
For additional commands, e-mail: issues-h...@iceberg.apache.org

Reply via email to