[ 
https://issues.apache.org/jira/browse/GEODE-9388?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17390207#comment-17390207
 ] 

ASF subversion and git services commented on GEODE-9388:
--------------------------------------------------------

Commit 7c04b86b45ed5b085bb7830405fed84333e9fe32 in geode's branch 
refs/heads/develop from Donal Evans
[ https://gitbox.apache.org/repos/asf?p=geode.git;h=7c04b86 ]

GEODE-9388: Implement Radish ZRANGEBYLEX Command (#6716)

 - Add ZRANGEBYLEX to supported commands
 - Introduce AbstractSortedSetRangeOptions class to handle behaviour
 common to -BYSCORE and -BYLEX ranges
 - Introduce SortedSetLexRangeOptions to handle parsing lexical ranges
 - Rename SortedSetRangeOptions to SortedSetScoreRangeOptions
 - Introduce MemberDummyOrderedSetEntry to support getting rank by lex
 - Rename DummyOrderedSetEntry to ScoreDummyOrderedSetEntry
 - Add unit tests for MemberDummyOrderedSetEntry
 - Add integration tests for ZRANGEBYLEX
 - Refactor RedisSortedSet.zrangebyscore() to use
 SortedSetScoreRangeOptions
 - Add missing HitsMissesIntegrationTest for ZRANGEBYSCORE
 - Refactor argument parsing in ZRangeByScoreExecutor to allow correct
 error behaviour with multiple LIMIT options, one of which is
 incorrectly formatted
 - Add tests to confirm correct behaviour for ZRANGEBYSCORE for above
 case

Authored-by: Donal Evans <doev...@vmware.com>

> Implement ZRANGEBYLEX Command
> -----------------------------
>
>                 Key: GEODE-9388
>                 URL: https://issues.apache.org/jira/browse/GEODE-9388
>             Project: Geode
>          Issue Type: New Feature
>          Components: redis
>    Affects Versions: 1.15.0
>            Reporter: Wayne
>            Assignee: Donal Evans
>            Priority: Major
>              Labels: pull-request-available, redis
>             Fix For: 1.15.0
>
>
> Implement the [ZRANGEBYLEX|https://redis.io/commands/zrangebylex] command 
> without the LIMIT option.
> +Acceptance Criteria+
> The ZRANGEBYLEX command has been implemented along with appropriate unit 
> tests.
> The  command has been added to the AbstractHitsMissesIntegrationTest.  The 
> command has been tested using the redis-cli tool.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to