[
https://issues.apache.org/jira/browse/GEODE-4254?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16320997#comment-16320997
]
ASF subversion and git services commented on GEODE-4254:
--------------------------------------------------------
Commit c968058937891eab157cde9dc186c5aba772e053 in geode-native's branch
refs/heads/develop from Jacob Barrett
[ https://gitbox.apache.org/repos/asf?p=geode-native.git;h=c968058 ]
GEODE-4254: Cleanup public macros. (#183)
- Removes TEMPLATE_EXPORT macro.
- Renames internal _GF_CACHEABLE_* to _GEODE_CACHEABLE_*
- Removes DINP_THROWONERROR_DEFAULT
- Rename checkBufferSize to internal _GEODE_CHECK_BUFFER_SIZE.
- Rename LIB* to internal _GEODE_LIB*
- Removes GFCEXTERN
- Rename CPPCACHE_EXPORT to internal _GEODE_EXPORT
- Removed inittypes.h redefinition
- Rename GF_NEW to internal _GEODE_NEW
- Rename FRIEND_STD_SHARED_PTR to internal _GEODE_FRIEND_STD_SHARED_PTR
- Converts PersistenceManager constants to constexpr.
- Removes ATTR_UNUSED
- Removes unused platform defines.
- Replaces platform macros with CMake config.h
- Moves geode_base.hpp and geode_globals.hpp internal.
- Extracts internal GfErrorType.
> Preprocessor macros should should be prefixed with GEODE_
> ---------------------------------------------------------
>
> Key: GEODE-4254
> URL: https://issues.apache.org/jira/browse/GEODE-4254
> Project: Geode
> Issue Type: Improvement
> Components: native client
> Reporter: Jacob S. Barrett
>
> All preprocessor macros in public headers should have the project prefix of
> GEODE_ to avoid collision with other libraries and application source.
> Unnecessary macros should be deleted.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)