We're in the process of migrating our Android builds from Qt 5.13.0 to 5.15.1. Something that has changed between these two versions is the default naming scheme for target libraries built using qmake. In our .pro file, we specify (for example):
TARGET = MyLibrary In Qt 5.13.0, this produced an output library named 'libMyLibrary.so'. But in 5.15.1, it produces libMyLibrary_armeabi-v7a.so'. So the filename includes the architecture type as a suffix. I'm aware that this is an intentional new practice with Qt Android libraries - that binaries for all architectures are built into the same target directory, with the architecture type distinguished by a suffix within the filename. However, for reasons that I don't really want to go into here, this naming scheme is inconsistent with a bunch of other libraries that we build in a different way, and I would like to make it _not_ include the architecture suffix - I want it to output 'libMyLibrary.so' as it used to in 5.13.0. I've rummaged through all the qmake variables but haven't found one that allows me to control this behaviour, or that lets me set the actual filename that is used for the output library. Can anyone advise how to do this? Thanks, Rob Allan
_______________________________________________ Interest mailing list Interest@qt-project.org https://lists.qt-project.org/listinfo/interest