On Sun, 19 Aug 2012 21:12:17 +0200, Daniel Vetter <[email protected]> 
wrote:
> Hi all,
> 
> Changes since last time around:
> - The prep patches are all merged now.
> - I've left out the actual DP fixes/cleanups, I think we should merge those 
> in a
>   separte step.
> - A few bugfixes (thanks to Paulo, Jani and Chris).
> - I've also applied a few bikesheds for naming that Paulo suggested (but I'm 
> not
>   sure whether I've sent those out already in a previous patchbomb).
> 
> Essentially this is just the core rework, which addes the new get_hw_state 
> code,
> refactors all the encoders to use the new functions and finally reworks the
> modeset logic to disable/enable entire pipes, always (and with a deterministic
> order).
> 
> For merging to -next, I plan to pull in everything with a real merge commit. 
> For
> that reason I've put up a modeset-rework-base branch onto my private fdo 
> repo[1].
> That way I can put a short documentation for the new modeset design into the
> merge commit (stichted together from the previous patchbomb cover letters),
> documenting my folly assumptions for eternity.
> 
> I'll also plan to put tags for the entire series in the merge commit, so if 
> you
> have tested this on a few machines, read through and agree with the new 
> designs,
> please reply with your tested-by/acked-by/reviewed-by tags.
> 
> Flames, comments and test reports highly welcome.

I've had a few read throughs of the patches now. I'm not confident yet to
review each and every one of them. To add to my wishlist alongside
reporting an error from modesetting, I would like for the debug log to tell
the complete story behind each mode change. In particular that every
decision point is instrumented and explained.

I am however happy with the direction it is taking, the extra sanity
checks are a major selling point along with the simple no-nonsense
approach to setting modes.

So Acked-by: Chris Wilson <[email protected]> and I'll keep
working through it. Quite a few of the patches are obvious enough to
r-b, but it is more important that we get some critical review of your
core design.
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre
_______________________________________________
Intel-gfx mailing list
[email protected]
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to