On Sep 16, 2012 4:55 PM, "Brian Harring" <ferri...@gmail.com> wrote: > > Folks- > > Keeping it short and quick, a basic glep has been written for what I'm > proposing for DEPENDENCIES enhancement. > > The live version of the doc is available at > http://dev.gentoo.org/~ferringb/unified-dependencies/extensible_dependencies.html
Am I the only one who thinks that this dep:{build,...} thing looks really ugly and is hard to read? IMO simply removing the "dep" part would greatly improve things: DEPENDENCIES=" :build,run? ( ... ) :run? ( ... ) " s/:/@/ would also be interesting DEPENDENCIES=" @build,run? ( ... ) @run? ( ... ) " Alex | wired