On Sat, 31 Mar 2012 22:49:07 +0400 Alexander V Vershilov <alexander.vershi...@gmail.com> wrote:
> Hello. > > It seems that in eclasses we have two differenct environment variables > with same meaning ESCM and EVCS OFFLINE. Some of eclasses use one and > some another: > > find . -type f | xargs grep -l EVCS_OFFLINE > ./git-2.eclass > ./bzr.eclass > > find . -type f | xargs grep -l ESCM_OFFLINE > ./darcs.eclass > ./cvs.eclass > ./mercurial.eclass > ./git.eclass > ./subversion.eclass > > It seems we should have some concusion about what env variable should > be used to prevent downloading of live repo. I think we agreed on using EVCS_. Quoting ulm: Coming back to this. As was pointed out in the thread in -dev (almost a year ago), these variables should better be named EVCS_*, because SCM is ambiguous with the scheme language. The category is called dev-vcs too. [1] [1]:https://bugs.gentoo.org/show_bug.cgi?id=311101 -- Best regards, Michał Górny
signature.asc
Description: PGP signature